View Full Version : robotis/bioloid zig2serial card

russell k horsell
10-30-2007, 03:13 AM
After reading the various (English) manual entries and a few web pages ("there is no manual specific to the Zig2Serial card") I'm still having trouble getting the thing to fire up.

I've wired a Zig-100 into the thing (I'm *pretty* sure it's around the right way -- but I've now seen photos with the thing in either orientation; but I've aligned it so the main xtal is on the appropriate mask blolb) and wiring 5v to the J10 (the square pin is GND since that connects to pin 5 on the DB9) and starting up the robotis terminal and typing "!" like mad (supposed to get the Zig-100 board to fire up into bootstreap/config mode at 57kb) the thing doesn't seem to even draw current and the status light sure doesn't light up let alone blink green.

I've been hanging around the Robotis page and asked them for the Zig2Serial manual that *appears* on their website, but can't be downloaded. So far, no go.

So the fallback now is -- ask someone else that may have gone the same route.

So what am I missing?

PLEASE don't tell me it's something to do with one of the "options" that appears on the Zig2Serial card as an "iron cross" on the mask (i.e. seems to invite you to drill out the plated-thru hole).

Thanks in anticipation,


10-30-2007, 04:51 PM
Here's how the Zig-100 modules should be mounted:

(Click to enlarge)

(Click to enlarge)

I marked the positive and negative terminals on the Zig2Serial, but it sounds like you have that wired up correctly anyway. I haven't actually tried running power directly to the board, bucause I've been using the USB2Dynamixel adapter, which supplies its own power.

As soon as power is applied to the Zig-100, you should see a rapidly flashing red LED. When the Zig-100 detects its sister module, the red LED will turn on and blink off once every few seconds.

If there isn't a light on or anything, hit the reset button on the Zig2Serial. Also, when you're sending the "!" command through Robot Terminal, you have to hold down the reset button while you hit [shift]+1. This may require some coordination. It should respond by printing the status of the Zig-100 to the terminal.

Let me know if this helps, let me know if it doesn't. In the meantime, I'll email our contact at Robotis and see if I can get you a real manual.

russell k horsell
10-31-2007, 12:53 AM
Ack that.

I've partly solved the problem.

I also don't have the usb2dynamixel -- I've bought a similar product from Jon H, so I figure I won't, either.

In any case, the man pages say the U2D is only used for its USB to COM port ability. But the man pages do mention 1 other little thing.

Turns out it supplies +5V on pin 9 of the DB9 and THAT's where the board expects to get power. Putting 5V on the J10 header has no effect with the default options. I'm pretty sure one of the plated-through holes (shaped like Iron Crosses) has to be drilled out to get the board to work off a normal COM port (or via my setup of a separate USB2Serial adapter that can't be easily hacked since it's so damn tiny and already seems to connect SOMETHING to pin 9 of the DB9.

With a bit of hacking I managed to get the red flashing LED working. I figure I'll use it this way for now -- figuring out how to get the P/S through J10 will wait for later.

There is a "kind of" circuit diagram in one of the Robotis Zig-100 manuals. At the end they have a "suggested" method for hooking the Zig-100 to a serial port. The suggested diagram seems to follow closely the actual Zig2Serial card, albeit some of the R's have been re-numbered and the circuit's use of J10 is not exactly the same as the diagram. :}

Thanks for the quick feedback.


russell k horsell
11-01-2007, 11:34 PM
OK. I found the "option". Near the J10 header there's an R10 marked on the mask. Drop a dob
of solder across this and the 5v supply on the hdr is connected.

11-05-2007, 02:49 PM
Thanks for the heads up russell:)

11-05-2007, 03:58 PM
Nice catch, Russell. Guess I didn't look at the traces closely enough. Call me crazy, but I really think that bit of info should be in a manual somewhere.

Speaking of manuals, I haven't heard back from Robotis yet. I'll shoot them another email this week.

russell k horsell
11-06-2007, 10:38 PM
Yeah, the manual(s) (thanks to various websites I have a growing collection for Robotis) are not great.

I've finally managed to piece together the last little nits I need to get my bioloids working via "zigbee RPC" thanks to decoding of the "word data" packet format.

I did this first by dumping a 1.14 version of the flash from a CM-5 and running it through some Linux utilities and a couple of roll-ur-owns then looking for the zigbee code.
It was only then I knew where to find the same info in the "Expert" manual a couple days later. :(

Same thing happened with this R10 header thing. As I said, I got out my loupe and tracked it down on the bd and about 48 hrs after that Robotis got back to me with the same info. But no Zig2Serial manual was offered.

Thanks for the feedback guys; robot development is like working in a hard vacuum here in the antipodese. :wink:

R.M.A. van Meer
01-17-2008, 12:54 PM
Dear Russell k horsell,

I've got a zigbee-100 and a zig2serial mounted + soldered them correctly, Xtal placing is correct. Plus i've soldered the R10 mask together. But still i don't get a light burning when i mount the device into my com-port....
I've soldered a ZigBee-100 onto my bioloid motherboard. no responce there too...

does any one have an idea what might went wrong ?? or what i need to do ?

there aren't any helpful manuals containing how to solder the zigbee-100 onto the motherboard or the Zig2Serial.

Thanks !

Ronald van Meer
Student @ Rotterdam University

russell k horsell
01-20-2008, 11:03 PM
The zig board in the controllers is the easiest to test.
Make sure it's in the right way and you'll probably also have to
solder it in. I initially tried relying on the gold contacts, but it wouldn't
work reliably once the CM5 was re-assembled.
To test it, try running a bioloid program that prints out the "my id" -- it
should be the same as the number shown on the zig100's packaging.
(My numbers were written onto white plastic the zig100's were pushed into;
the numbers may also be on the actual board itself in either hex or decimal).

The zig2serial took a couple of weeks to get going, due (as you say) to lack of

But the trick for me was the J10 jumper. Once that was shorted and a 5v power supply
attached to the nearby jumper (I think the square pin was ground, but check that -- my memory is often wrong :} ) the LED lit up when power was applied.

To get the zig2serial working you'll need the "robot terminal" program or MiniCom or some other
program that controls serial ports and try to push the "!" key on MiniCom (or whatever) at the same time you're appling power, and the board will get into a "configure" mode. The document for that is in one of the standard manuals.

The initial baud rate for starting the zig2serial the first time is (again, my memory!) fairly
standard. My MiniCom setting was right the first time, so it was likely 9600 baud 8 bits no parity.
If that doesn't appear to work (or the typing appears scrambled) then try 11.2 Kbaud, 8, no parity.

I've managed to use all the Zig boards I have, so they seem fairly rugged. That is, they've not been damaged by all my mis-handling. :)

Once you have the Zig going, you may need to understand the protocol between the Zig on the CM5 is not plain text -- it uses 6-byte messages to send 16-bit values, sending the lower 8bits and upper 8 bits, along with their completents. Unless you have that right, a "get word from radio TX buffer" will never return.



06-25-2008, 03:47 PM
This is the same for me no lite.

I pluged my zig100 in to the com port and no light. should i solder the r10 conection together then it will work?

09-29-2008, 01:09 AM
Thanks Russell & Dave! The great information on this thread has gotten me underway with wireless communication to my Bioloid.

I wasn't able to establish a connection with minicom, but I did with gtkterm.
I set gtkterm to 57600, 8bit, no parity and was finally able to access the zig-100 setup. Thanks Dave for the clarification on holding the reset button while pressing "!". The manual is a bit cryptic on that point.

Russell, thank you for your sleuthing on the R10 header thing. I really didn't like the thought of having the power wires on pins 5 + 9, J10 is much nicer.