PDA

View Full Version : 0/0/4 relay problem



mikertx
02-21-2008, 02:57 PM
Hi Folks,

I've been using Phidgets for about a year for various astronomy related control project but this is my first posting to the forum.

I'm using a couple of 0/0/4 USB relay control boards and so far have only been using 2 of the relays. I'm developing a new application and I have found that on one of my computers I can't turn on more than 2 relays at a time without the board briefly disconnecting and thus turning off the relays. On another computer I can turn on 3 relays at once but not all 4. In both cases these are direct connects to the PC usb ports. I tried using a self-powered USB hub (two different ones) and in both cases the phidget is not detected as attached at all. All of this is testable with the interfacekit-controller.exe program so I know that none of my own software is involved in the problem.

Any suggestions greatly appreciated.

Mike

fitchett
02-22-2008, 12:10 AM
Hmm, never heard that one. Old boards? New boards? Can you get the deviceVersion?

Chester

mikertx
02-26-2008, 09:30 AM
I have reproduced the problem with a new, version 707 board and with an older 706 board. There is a difference however. With the 706 board I can turn on 3 relays and it only resets when I try to turn on the 4th. On the 707 board I can only get 2 relays turned on and it resets on the 3rd.

This is very easy to test. With just the 0/0/4 plugged into the USB port I use a simple ohm-meter to check the state of the relays. No other connections at all.

Is there anyone who can actually turn on all four relays at the same time on one of these boards?

Thanks,
Mike

cmmguy
03-03-2008, 07:04 PM
Never had a problem with a 0/0/4. In fact I have two still running on the factory floor since 2005 every day, 24/7 controlling stacklights.

Alex
03-05-2008, 02:44 PM
I just tested the one that I had (ver 706) and I was able to turn on all four with no problem... I hooked up a multimeter to each port and tested both the NC and NO.

Are you running the Phidget manager (Ph icon in the system tray) and using the demo program by double clicking on the device in the list?

dogbot10
12-29-2008, 08:25 AM
I had the same problem, and I fixed it by turning off the PH icon running in my system tray. The program interferes with other programs communicating with the 0/0/4 phidgets, even when the demo is not running. You can do this by right clicking the icon and then pressing exit.

I can now turn all four relays on and off without any problem.

Adrenalynn
12-29-2008, 02:06 PM
Thanks for following-up with the answer, Dogbot! +Rep - and welcome to the forum!