View Full Version : A different kind of request for help on a cm-5

03-08-2008, 09:14 PM
ok here is whats up. frustration reached its top level today and I ordered another cm-5 unit. here is what I am wondering,anyone want to see if they can figure out the old cm-5? I am willing to send it to you and even pay for some service. basically this thing is useless to me know,unless I have the same prob when the new one gets here,but even that will prove that it is in the interface of the dynamixels,another words baud probably but I have reset them ,one by one,numerous times and nothing still.
any takers on this? ;)

03-08-2008, 09:40 PM
what's the problem that you're having with your cm-5?

03-08-2008, 10:06 PM
cant get it to recognize the servos,seems to download everything alright then in robot terminal it doesn't find them,and in the behavior programmer I get the 8100,this all started with my installation of a zig 100,then removal of said unit,it was working fine until then.

03-10-2008, 01:57 AM
trey, do you see any visible damage on it after you removed the zigbee? You should inspect traces on the PCB and make sure it didn't get damaged. I probably wouldn't toss out your old CM-5 yet. I would probably try to work with Robotis to get it repaired or to get a new one. It would be worth a shot with a new CM-5 to see if you see the same symptom.

Not being able to recognize the AX-12+s and the AX-S1s is a bad sign. Was it ever able to recognize it? Were you able to talk to the AX-12+s before installing or removal of the zig-bee?

03-10-2008, 10:32 AM
no damage that I could see,even with the help of a magnifier,that was my thought also that I had damaged it on the install or uninstall. and it did work fine before I installed the zigbee so I know its something I did. what gets me is I can control the servos through robot terminal,but it says their are no servos,weird. thats kinda why I think their is a user error in loading the software or something to that ens,though I have gone through every step in the manual numerous times.:robotindifferent:

03-11-2008, 09:30 AM
have you tried to reload the firmware onto the CM-5? I think the latest is the *115.hex file.

03-11-2008, 07:05 PM
yup even downgraded the firmware,113hex,its killing me!

03-13-2008, 09:31 AM
Trey, any luck with the new CM-5 unit?

03-13-2008, 02:25 PM
just got and guess what? exact same prob! witch is kind of a relief, glad to know its me and not the hardware.
now to wrap the new one back up and start from the beginning with the old one.

03-13-2008, 02:28 PM
heres a screenshot of both cm-5s the reset comand was given to the old one,not the new one.

03-13-2008, 08:57 PM
ok here is a screen shot of robot terminal connected to cm-5 via dyna mixel usb adapter with servo one plugged into bus,cm 5 in manage mode and press start.

what would you do next? I will post results,thanks!

03-14-2008, 10:17 AM
Have you tried plugging the CM 5 into your PC using just a serial cable and not the USB Dynamixel adapter?

I don't own a bioloid, but from what I read about the dynamixel usb adapter, the servos are supposed to interface directly to that? I could be completely wrong here though.

03-14-2008, 07:56 PM
ok well its definitely in the cm5 software,I can control the servos via dynamixel configurator. I checked Id and baud{100000bps}

03-15-2008, 02:16 AM
And you get the same issue with a serial port connected directly to the CM-5, without the use of the dynamixel usb adapter?

03-15-2008, 06:08 AM
need another pc to try that one,will have the answer tomorrow morn!

03-15-2008, 11:33 AM
success! of sorts! the old cm-5 still exhibits the same behavior on another pc,but the new one now "see's" the servo and took the behavior program for crosswalk and will move like it should! now I need to figure out whats the deal with the usb adapter and the problem with the old cm-5,does trossen do repairs on them? or will I need to send it back to robotis?

03-15-2008, 11:54 AM
Possible the old CM-5 is bad or didnt take the firmware flash.

The Dynamixel USB adapter sounds like its working as intended, from what I read its not meant to interface to a CM-5, rather its meant to interface directly to the servos.

Good to hear youre up and running though!

03-15-2008, 03:47 PM
no its made to interface between a computer without a printer port,or to use the zig100 module,the manual goes through the process of using it that way. I am still of the belief that its something I have done not hardware related.

thanks for the suggestion Of another pc though been meaning to try that just couldn't believe this laptop would work when my old desktop would!

03-15-2008, 08:59 PM
trossen do repairs on them? or will I need to send it back to robotis?we don't do repairs, but if it's defective then we'll definitely either exchange it, give you a refund or whatever you want to do:)

03-17-2008, 06:24 PM
thanks alex! thats the route I am gonna have to go,I will give you a call and we can go from there.

03-17-2008, 06:43 PM
I'm out of the office right now. I'm usually in from 8am - 5pm CST.

03-22-2008, 07:49 PM
thats fine I am not in a hurry,still pretty sick

03-23-2008, 04:10 PM
Well glad to hear that you got it working =)

03-24-2008, 07:42 AM
You may want to check what the reply time register is set to on your servos. Maybe they are returning their status codes too early or late...

You also sent a reset command. Did you do this while multiple servos were hooked up? You may have set them all to ID=1 and they are all trying to respond at the same time.

Connect a single servo and test that, I don't have a servo with me now but you may want to have a list of "normal" values to compare with.