PDA

View Full Version : [Bioloid] Multiple problems



Dmonious
05-01-2008, 09:02 PM
I got a bioloid for christmas and I was never able to get any of the walking programs to work. The simple robots worked ok but any of the walkers would spaz out and blow a fuse (especially the humanoid). I recently purchased the beginner kit (I started with the comprehensive kit) and I'm having similar problems. The side sensors on the dynamixel don't seem to work on my new set.

Here's some of my specs:

O.S.- vista and xp
pc -2 hp laptops 1 hp desktop

Original bioloid:
behavior control ver 1.30
motion editor ver 1.24

Latest bioloid
behavior control ver 1.32
motion editor ver 1.26

data cable adapter: Dynex dx-ubdb9 usb to serial adapter. Usb 1.1 500kbps transfer rate.

I uploaded a couple of screen captures to give you an idea about what's going on. Any help would be appreciated.


I get the same results irregardless of which pc I use.

tom_chang79
05-02-2008, 02:00 AM
I don't quite understand what you mean by spazzing out and blowing a fuse. Make certain that your workmanship is good, no binding, no obstructions to any of the hinges... If you are having trouble making your humanoid walk, first make sure to run the "check" program, where the bioloid extends out its arms and angles the legs slightly so that the humanoid is at a "t" position. Next, make sure you step through by pressing one of the buttons (forgot which, check the quick start guide) and make sure the servo's LED lights up in sequence according to their ID.

When you mentioned "blowing a fuse," do you mean blowing out the fuse that are in the CM5 unit?

JonHylands
05-02-2008, 07:58 AM
If you're blowing a fuse, chances are you've ground the coating off a couple wires, and they are shorting them together.

- Jon

LinuxGuy
05-02-2008, 09:05 AM
If you're blowing a fuse, chances are you've ground the coating off a couple wires, and they are shorting them together.
I did this to one of the servo wires on a servo in my Lynxmotion BRAT. I think that caused the Atom PRO and maybe Bot Board II to be damaged before I realized what was wrong. Now I have a BRAT waiting for a Hammer-RDP. I am hoping there was no damage to any of the servos.

8-Dale

Dmonious
05-02-2008, 09:55 AM
By spazzing out I mean the robot contorts to the point that it overtorques the ax12s and blows the fuse on the cm5. The only bot that blows a fuse is the humaniod. The walking droid just walks in a counterclockwise circle and when you put your hand in front of it, it spreads its legs and falls on it's back (if only I can get my girlfriend to run that program). The check assembly program works fine for all bots. All leds light up in the correct sequence. It doesn't matter if its the walking droid, gerwalk or the humaniod. All of these problems are related to my original comprehensive kit. The beginners kit I purchased has a different set of problems. I was trained as an electronic warfare systems tech in the U.S. Air Force quite a few years ago, and I was also a computer field engineer for about 8 years. Troubleshooting is what I do. I purchased the beginner kit to make it easier to eliminate the cm5 as a problem as well as the sensor module. I also wanted the extra servos to make an articulated waist. I am a relatively experienced roboticist. I started with the mindstorms 2.0, then multiple robotix sets, then the nxt, and all of the wowwee ambulatory robots (although the wowwee bots are so limited that I can hardly count them). I'm providing this background info to let youse (yeah I know it's not a real word) know that I'm not a complete newbie, although I feel there's always something new to be learned. Here's another thing, the graphics on the motion editor only shows the servo positions and not the picture of the robot. I love robots and I don't want to return my sets, I just want them to work correctly so we can take over the world! Bwahaha!

JonHylands
05-02-2008, 10:05 AM
Generally, when an AX-12 over-torques, it shuts itself down automatically, and freewheels. This happens with the default settings, unless you've changed those specific settings in the control table of the servo.

You may be getting into a situation where you are asking for more current than the CM-5 can provide, in which case it may blow the fuse. However, you should really check over your wires very carefully, especially where they feed through brackets. Also, its really easy to pinch the wire that connects the two hip/ankle servos when you put it together, and that may be causing issues like that.

- Jon

Matt
05-02-2008, 10:13 AM
The walking droid just walks in a counterclockwise circle and when you put your hand in front of it, it spreads its legs and falls on it's back (if only I can get my girlfriend to run that program).

LOL, that was great. Hilarious.

trey3670
05-02-2008, 12:05 PM
well I can vouch for the cm-5 being finicky,first off you have two running different software versions,I would start there and eliminate that part,get both cm-5s on the same revision I mean. I have d-loaded some programs from the web,some work others send my bioloid into the spaz like what you are talking about,the good news is no 8100 errors! and check the cables,they do bind and cut the insulation allot.

Dmonious
05-02-2008, 02:17 PM
Before I get started I'd like to thank all of you for your replies. For the moment, I'd like to disregard the 2nd bioloid kit I purchased and deal with the first. A little history: The first bot I built was Gerwalk. The check assembly program worked fine (they all do) but as soon as I ran the demo program it spread both feet and fell down. No error messages. Finding that odd, I decided to build the humaniod. The humaniod contorted terribly (like a special ed kid without his meds) and blew a fuse. I did disassemble and reassemble all the leg joints but to no avail. I then decided to build the crossing gate. Worked ok. I then built the sound level bot. Worked ok. I then built the walking droid which did the counter clockwise walk with the leg spreading and the falling on the back after waving my hand in front of it. (Sigh). I then decided to make up my own program to see if the droid would walk properly and it did but when I tried to get it to back up it did it one time then gave me an error message and stopped working. I had to make up my own walking routines in the motion editor by the way. I'm wondering if the problem might not be with the usb to serial adapter. I'd hate to spend nearly another 100 bucks to find out thats not the problem. All problems are related to walkers both in the comprehensive and the beginners kit.

trey3670
05-02-2008, 05:31 PM
ok well lets start at the beginning,don't think I am doubting your abilities but lets start eliminating stuff.
when you built the bot did you pay attention to the marks on the servos? they have alignment marks,simple I know but sounds like that could be one reason.

TechMech
05-02-2008, 05:45 PM
I blew fuses with my Bioloid kit as well . The servo's were doing the contortion thing to.I then realized I was not loading the motion files first before loading BCP program. Once I did that no more blown fuses.

trey3670
05-02-2008, 07:02 PM
good call tech mech I have done that,didnt blow any fuses but did go into contortions,had forgot about that.

Dmonious
05-02-2008, 09:48 PM
Trey, all the alignment marks were at 12:00. I was about 3/4 of the way through my first bot when I realized what all those pesky check alignment little boxes were talking about. Seriously. Luckily most if not all of the ax12s were properly aligned. Learned my lesson. Doubt all you like my good man! Lord knows I sure do. Techmech, why would I have to load the motion files for the walkers when I don't have to do that with any of the other bots?

trey3670
05-02-2008, 10:38 PM
glad you understand,heheh. the servos should have aligned with the mark on the servo horn aligned with the mark on the servo case,and yeah iv done the same thing. as for the other I know you have to load the .mtn file and then the .bpg file for everything to work properly.

tom_chang79
05-03-2008, 02:03 AM
You might have to load the motion files for the walker because they are probably in its own set. The rest of the bots in the tutorials are relatively simple, so maybe they balled up all the motion files into a single file for the other simpler bots, but the king spider, humanoid, and to some extent the gerwalk, have many pages of poses just for one motion. I was under the impression that all of the bots that you can build with the kit required you to load its respective motion files.

I have always loaded the motion files first, *.mtn, then loaded the *.bcp. If you look at the .bcp file in the behavior control program, it depends on the values of the servos to be there in each of the poses.

Personally, I've added a 19th servo to the waist-rotate. When I would turn on my humanoid, the waist rotate would rail and spin counter-clockwise. I had to disconnect the 19th servo in order to run the demo program for the humanoid. I later found out, to my chagrin, by "auditing" the various pages that are called out in the *.bcp in the motion file, that some values for the 19th servo was left blank for some of the poses. Not all the poses had a blank-value for the 19th servo, but some of it did.

If there are blank values for the servo id, it will cause that servo to do a continuous rotation when you call that pose to be played.

I would definitely make certain that you load up the default humanoid motion file into your CM5, then load up the behavior control file, making certain that you don't have blanks in the motion file by opening it back up in the motion editor, after loading into the CM5.

When I initially started to play with my Bioloid, I've accidentally loaded the motion from the CM5 onto my computer, causing it to overwrite my default humanoid motion file with whatever file that came defaultly flashed onto the CM5. Then I re-loaded this file back into the CM5, and my humanoid would go hay-wire. I later figured out what I did wrong, and restored the original motion and behavior file from the Bioloid CD.

If you have doubts about whether your default humanoid motion file and behavior file are corrupted, try uninstalling the Bioloid through your Control Panel->Add or Remove Programs, then go into that directory after the uninstall and delete the rest of the files left in there... Then re-install the Bioloid CD so that it will copy a fresh set of motion and behavior files. If you have any of the old motion and behavior files, I believe the Bioloid CD will not try to over write it, causing you to be back at square one...

Dmonious
05-03-2008, 09:06 AM
Man, I feel silly asking this but, what exactly do you mean by "loading the motion file"? Does that mean saving every page that is addressed in the bcp file individually? For example: the bcp file for the walking droid makes calls to motion page 1, 12, 13, 14 and 15. Does that mean I have to load these pages individually, save each one then run the bcp? I'm pretty sure that's not whats meant but I had to ask. I hope the problems me, I really do. By the way, I did as you advised Tom and uninstalled the bioloid software, looked for (but did not find) any remaining robotis or bioloid software, rebooted then reinstalled it. Unfortunately with the same results. a curious thing, when I reopened the bcp it defaulted back to the walking droid program as if it didn't get rid of all of the info. Maybe something remained in the registry. As an aside, when I load the walking droid bcp on my original cm5 it walks in a clockwise (not counterclockwise ((my bad)) circle then spreads legs and falls on it's back when something is in front of it. But my new cm5 just gives me an read page error 00f and does nothing. Both cm5s are ver115. All programs up to the walkers seem to work fine. Thanks again for your time

trey3670
05-03-2008, 12:16 PM
let me see if I can help there,when I want to run the demo for the bioloid in biped configuration I connect via usb dynamixel to bioloid turn him on,click start,click all programs,hover on robotis,hover on applied robots,advanced then click on humanoid.
that brings up a window that has the .mtn file in it,it has play and then the film symbol under it,double click that one and it will connect directly to the cm-5 and choose write to robot,after that choose the other humanoid demo with the three computers for an icon that will then open the behavior control program click on the serial cable Icon at the top of the page and it brings up another window to download to robot,let that finish and disconect the bioloid get the mode to play then press any of the 4 u,r,l,d buttons and he should perform,there is also a demonstration if you press start twice!

Dmonious
05-08-2008, 07:45 PM
Folks, I'm happy to say that both my walking droids are up an at em. Well they were till I tore one of them down and built the humanoid. He did his demo just fine. Trey, Tom thank you very much for your time. I kept attacking the problem from a hardware standpoint and just perused the software end of it. Sigh. Thanks again.
I am Wile E. Coyote, Super Genius

Adrenalynn
05-08-2008, 11:36 PM
Cheer!

Trey - Awesome walk-through! Great detail! Hats off to Trey and Tom. This looks like a write-up for the site's knowledge-base when Alex gets it up.

tom_chang79
05-09-2008, 01:04 AM
Dmonious, glad to hear that you got your Bioloid working! Now it's time for the fun part, dev-ing!

TechMech
05-09-2008, 04:40 PM
Cheer!

Trey - Awesome walk-through! Great detail! Hats off to Trey and Tom. This looks like a write-up for the site's knowledge-base when Alex gets it up.

Hey now I helped a bit to ! ;) Congrats Dmonious on getting your Bioloid running

trey3670
05-09-2008, 07:24 PM
yes you did techmech it was a community effort! glad you got it going now I need to decide on weathe or not I am going to order that bluetooth module............

Adrenalynn
05-09-2008, 07:39 PM
Well, I suppose a little. [:p]

Grats!

Alex
05-21-2008, 11:32 AM
Trey - Awesome walk-through! Great detail! Hats off to Trey and Tom. This looks like a write-up for the site's knowledge-base when Alex gets it up.The TRC Tutorial Section is up now for beta testing! If anyone wants to join the beta testing team, contact Matt (http://forums.trossenrobotics.com/member.php?u=3) or Dave (http://forums.trossenrobotics.com/member.php?u=4) :D