View Full Version : [Bioloid] sparkfun bluetooth module

07-16-2008, 01:23 PM
ok got this in and soldered up to my bioloid, my question is do I need to do anything to the module itself? I can get it to connect with both my desktop pc (with a bluetooth dongle) and my laptop (built in bluetooth). when I use bioblue to try to control it it will conect and the green light on the sparkfun will come on but when I click on an action to be performed the rxd light on the cm-5 blinks once then nothing.
I have another thread at robbosavvy (thats where pev the iventor of bioblue posted it) and srobot has helped quite a bit(thanks man!) but we still cant figure it out,any ideas? :confused:

07-16-2008, 01:31 PM
I don't have either, but at a guess, any time I see something's RX flash and nothing happen, I start looking at baudrate/parity/start-stop bits. Unless the software is automagically setting up the communications parameters...

If you do need to plink around with the communication parameters, make sure you reboot the CM5 each time. Processors can get easily confused when they get what appears to them to be spurious garbage data.

Again - just a guess, though!

Can you hook the receiver (CM5 side) up to a PC over serial and get protocol xraying set up? (I can link you to good free/share ware for examining RS232 ) and make sure it's sending what you expect it to send?

07-16-2008, 01:38 PM
You need to make sure to set the Bluesmirf to:

Baud Rate: 57600
Data Bits : 8
Stop Bits : 1
Parity : None
Flow Control : None

I believe it defaults to 115200 baud. You can set this via a telnet session.

To configure the bluesmirf via Telnet session.

1. Make sure your bluesmirf and bluetooth wireless dongle connect and create a virtual serial port. Make note of this.
2. Launch Hyperterminal (should be under All Programs > Accessories > Communications)
3. It will prompt you to create a connection, name it whatever you want.
4. Next screen will be the Connect To menu: Country, area code and phone number don't matter, however you need to set "Connect Using" to the com port that your virtual bluetooth serial port assigned.
5. It will bring up COMX Properties, just set the baud rate to 115200 and leave the rest as default.
6. File > Properties > Settings Tab > ASCII Setup > Checkbox- Echo typed characters locally
7. Type the following into the terminal, hitting Enter after each command:

+++ (It should respond with “OK”)
AT (It should again respond with “OK”)
ATSW20,236,0,0,1 (This won't respond with anything)This should set it to 57600,8N1 which is what you want it as. Disconnect the session and power cycle the Bluesmirf, you should be good to go. Let me know if this doesn't work out for you or if you run into any problems.

The bluesmirf only works with the Robot Terminal due to the Motion Editor and the BCP not keeping a consistent baud rate during operation. See if you can get it to respond in the Robot Terminal.

07-16-2008, 03:24 PM
0K i believe i have followed your directions up to the point of typing the commands into hyper terminal,it will not let me enter any info into the feild?

07-16-2008, 03:31 PM
Bah - friends don't let friends use hyperterminal...


Direct Download:

You'll probably need to turn echo on to see your commands, trey.

07-16-2008, 03:35 PM
I suggested Hyperterminal to keep things simple, as it comes with windows.

Bah my bad, I've had echo turned on by default for a loooong time.

File > Properties > Settings Tab > ASCII Setup > Checkbox- Echo typed characters locally

That should fix you up. Sorry for the confusion, I'm at work so I'm pulling this from memory.

07-16-2008, 04:43 PM
ok checked the box you specified,now the characters show up in the feild,when I click enter it just returns the cursor to the begining of the line? and many thanks for the help,this is not my feild and I apreciate you taking time to walk me through it!

07-16-2008, 04:47 PM
if you just punch in:


And then hit enter, it doesnt return "OK"?

Make sure you have the correct com port connected for that connection profile.

07-16-2008, 04:54 PM
yup got the right com no ok,just returns the cursor back to the beginning of the line

07-16-2008, 04:55 PM
Also, do you have TX going to TX and RX going to RX? Sort of confusing that it's like that.

I have the two outer CTS pins connected as well. Once I get home I'll double check all my settings, I'm pulling almost all of this from memory right now.

07-16-2008, 04:58 PM
and i set the baud rate to 115200,not sure whats happening

07-16-2008, 04:59 PM
thats my next check I will have to disassemble the cm-5 to check but I am pretty sure it is. and yes I have the jumper between the two outer pins.

07-16-2008, 05:04 PM
tx->tx, rx-rx is a crossover. It's a poor design that has haunted us since the dawn of the PC. The PC was never intended to be a "computer" - IBM intended it to be a terminal for their mainframes.


07-16-2008, 05:04 PM
Try changing the baud rate, maybe yours doesn't default to 115k.

07-16-2008, 05:16 PM
went through all the bauds,no change,will check connections now

07-16-2008, 05:22 PM
went through all the bauds,no change,will check connections now

Connections honestly shouldnt matter much as this communication is occurring before the CM-5 is involved. Let me double check all my settings when I get home.

07-16-2008, 05:32 PM
connections are correct

07-16-2008, 08:06 PM
are we sure that I can change the baud rate through the hyperterminal? or do I need to connect the bluesmirf directly to the pc?

07-16-2008, 08:29 PM
are we sure that I can change the baud rate through the hyperterminal? or do I need to connect the bluesmirf directly to the pc?

I configured mine via bluetooth wireless alone. A lot easier than rigging it up to your serial port.

PM inc, let's chat via phone and get this hammered out for you.

07-16-2008, 10:32 PM
Attached is the hyperterminal file I'm using.

07-17-2008, 10:41 AM
Hi1, just chipping in, my problems, were com port, and loading the bioblue programs into RN-! working with PEV sorted those issues out.

07-18-2008, 12:40 AM
well after two hrs on the phone last night with tyberius (thanks again man) we still didnt get it working. what we have narrowed it down to is
1. I need to get hyperterminal 5.1
2. drivers,you need the correct drivers for this aplication and apparentlly they do not come with the dongle and there is no link with the bluesmirf module.

there is a possibillity that the module is bad but I am not gonna give up on it yet,it does light up and it connects as a serial port. I have not had time to work on it today,maybe tomorrow its looking like time is gonna be tight though.
I will keep this thread updated and let ya know!

07-18-2008, 01:04 AM
I would think about switching terminal software.

Tera Term Pro, or much cooler for sniffing the protocol stack is something I just stumbled upon a month or so ago - "realterm"

Realterm does some protocol decoding and color-coding the full binary stream back and forth.

Ultimately, though, I'd put my oscilloscope on it...

07-18-2008, 07:18 AM
Tera Term alone is limited to COM1-4, and his bluetooth dongle keeps grabbing 5. I sent him a link to Putty to try out instead.

Problem with his version of Hyperterminal is it lacks ANSIW emulation, which shouldn't matter... but at the same time I'm trying to rule out any variables.

Lastly bluetooth drivers are a nightmare. Certain dongles choke on certain revisions, seemingly at random.

We'll get it figured out, I'm not entirely convinced its a bad unit yet. (Though his does not respond via LED like mine does, which is strange)

07-18-2008, 10:39 AM
Actually, Tera Term Pro hasn't had that limitiation in quite some time. RealTerm even less.

The only bluetooth drivers I've EVER found worth squat are the BlueSoleil drivers.

07-20-2008, 08:53 AM
the only time I had problems connecting laptop to RN-! was in a store with a lot of flourescents I ended up going outside, making conn, then going back inside and running Demo. blusoliel drivers work for me:) PEV also helped me get Bioblue working.:D good luck

11-18-2008, 01:55 AM
I have the Bluesmirf Silver (chipset BGB203) and the default baud rate for mine was 9600

I got it working with my ssc32 somehow but still haven't been able to set the baud rate to 115200 or get any response from commands with a bluetooth connection.
I think you need to use a RS232 to TTL level converter to program it initially because you can't program it over a bluetooth connection until it's configured to do that oddly enough.

I found a great guide for it on the following site:

And I found a really cheap RS232 to TTL level converter here