PDA

View Full Version : [Question(s)] ArbotiX / Dynamanager problem



vali
03-19-2018, 06:20 AM
Hello Everyone,

I am new to the forum and I am quite new to the world of electronics, I am probably less experienced than the majority of you so please be patient :o
I am trying to upgrade my skills quickly and for my new project I am using Dynamixel AX-12Amotors. I am trying to do my best to learn fast!


I am facing few issues at the moment and I would really appreciate if anyone could give me some help!


First problem I am having is with Dynamanager. I followed all the steps on the trossen page
and downloaded the dynamanager code as well as the ControlP5 Library (http://www.sojamo.de/libraries/controlP5/).
When I run the processing file (dynamanager) I get the error that the function valueLabel does not exist. I managed at some point to make it work but then .style was not recognised (line188) and other functions, so I wonder if I have some library missing?



Did anyone faced the same problem? Is there any step-by-step tutorial I could follow to make dynamanager work properly?


Thanks in advance for your time!

tician
03-19-2018, 04:11 PM
Why are you trying to build from source instead of using the pre-built stuff (http://learn.trossenrobotics.com/index.php/getting-started-with-the-arbotix/1-using-the-tr-dynamixel-servo-tool#&panel1-1)? Did the binary releases (https://github.com/Interbotix/dynaManager/releases) not work for you?

vali
03-20-2018, 12:01 PM
Thanks a lot Tician, you are right, for some reasons I didn't have the batch file, so I tought I had to run the source code. But after your post I double checked, I run it and it worked!!