PDA

View Full Version : [Question(s)] Arbotix Robocontroller revival; setup help appreciated



skymaker
05-19-2018, 10:09 PM
Hello,

I am dusting off a somewhat dated PhantomX Pincher kit, and am trying to get it talking to my laptop running a recent version of Ubuntu.

I have attempted to use Arduino 1.0.6 as seems to be recommended by the Arbotix install instructions, and I seem to have successfully got Arduino configured to work (Arbotix libraries installed, Robocontroller USB serial seems to be recognized, sketches compile in test, etc). However, when I try to upload one of the Arbotix test scripts, I get this error;


Binary sketch size: 1,336 bytes (of a 65,536 byte maximum)
/home/USER/Documents/arbotix-robocontroller/arduino-1.0.6/hardware/tools/avrdude: error while loading shared libraries: libusb-0.1.so.4: cannot open shared object file: No such file or directory

...and I am unsure of how to fix this, or where to look for more instructions on how to fix the issue. If I am not mistaken, it looks like some driver or script that Arduino 1.0.6 expects to be there for the actual upload step over USB has been changed or moved in later versions of Ubuntu.

Worst case, I can try and run an older version of Ubuntu in a VM or something, but does anyone have a better idea on how I can get this running? Thanks.

jwatte
05-21-2018, 07:35 PM
You need to find the old version of libusb to match. I think there's an apt package for it? Try "apt search libusb" to see what's available.

Also, I think there might now be support for ArbotiX with Arduino 1.8.x? If there is, you should definitely upgrade!

tician
05-21-2018, 07:52 PM
http://forums.trossenrobotics.com/showthread.php?7971-ArbotiX-1-6-Files-Libraries
Scroll down to KurtEck's December 2017 post.