View Full Version : [Question(s)] WidowX + MoveIt Buggy Behavior

06-07-2018, 02:59 AM

I've been working with a WidowX for the past few months now on a grasping project and I've been running into some weird behavior. Currently, I'm having the arm grasp and drop a small toy (weighs almost nothing) repeatedly for several hours. But at seemingly random times, the arm will freeze while attempting a grasp and resume operation 10-15 seconds later, skipping instructions as if nothing happened (it's as if the servos were fast-forwarding through the missed instructions while attempting the current ones). I'm using MoveIt to control the arm, and there's no error message or handling for this -- the MoveIt log will say that the trajectory execution succeeded and will also continue to pretend to execute trajectories while the arm is frozen.

I've tried replacing all of the wiring between the servos (as per some older forum posts with similar issues), adding pauses between commands, and swapping servos but nothing seems to make a difference. I've tried letting the servos rest for 20 or so minutes before resuming operation, but the bug still appears. Perhaps not running the arm continuously for longer than an hour or so might make a difference, but that seems awfully short for a reasonably sturdy arm like the WidowX.

Also not sure if this is relevant at all, but the arm is mounted upside down (objects are still on the floor, the arm is just mounted differently).

Any help at all would be greatly appreciated -- I've been struggling with this for some time now. If a video of the behavior would be helpful I can try and get a recording posted as well.