View Full Version : [News/Announcement] Turtlebot3 with Openmanipulator

01-22-2019, 05:22 PM
It seem it is being renamed the Openmanipulator-x now.

01-22-2019, 09:18 PM
looks like hours of entertainment

01-29-2019, 07:56 AM
LOL. It is not even here yet and I am having issues.
I tried to update a OpenCR board and now I have two OPenCR bricks.:confused:
Sigh looks like hours of entertainment, starts now.

01-29-2019, 08:29 AM
I have not done anything with mine for a few weeks now. Been busy with Puppy and with the Teensy 4 Alpha board.

Sometimes when I had issues iwth OpenCR board, I need to revert back to using the RPI (or UP) board to reprogram the board with current default firmware, before I could get it to talk again on Arduino...

01-30-2019, 04:45 AM
:o Thank you. I found page 248 in the book were you press the reset and switch 2 which forces the boot-loader to run, yea!
That really had me thinking I bricked my boards when I noticed, I was not the only one with the same issue, so I re-read the BOOK and
lo and behold there it was, and the only place I have ever seen mention the use of switch 2, so yea again!!

01-30-2019, 07:53 AM
Glad that worked - Just in FYI - It is also in their e-manual...

01-30-2019, 10:48 AM
Well with that out of the way it's back to waiting for a package :tongue:.
Look at the http://www.robotis.us/ site they have a frame set and a heavy base plate for the manipulator.

02-01-2019, 03:31 PM
Here it is. I downloaded the build instructions, as this one comes with no instructions, but useful links :wink:
There Disclaimer really needs to be more visible. i.e Base plate is sold separately like the power supply and a controller .
The 5 Dynamixel's XM430-W350-T's come with ID's set to 11 through 15, maybe a hour and the hardware is done.
I would install it on my turetlebot3 waffle but I must play with it, before going mobile.

02-11-2019, 11:14 AM
The default configuration for the manipulator is on the u2d2 or a USB serial connection, and it works really well.
They have a direct link to some STL files for 3-D printers, so I printed some motor covers to round out the sharp corners and looks more robust some how :o.
With a edit to the launch file the OpenCR Board runs the OpenManipulator. :cool:

03-09-2019, 04:30 PM
I am happy to report that I have been able to get everything working, with the exception of the RC100 joystick with the OpenManipuiator. It should work but hum:confused: I am still working on that one. I kept loading the OpenCR chain instead of:
Go to Examples → OpenCR → 10.Etc → usb_to_dxl on Arduino IDE for OpenCR. Was making me crazy.:genmad:
It looks like there doing some good stuff with ROS Industrial for the OpenCR Board, Yea!

04-15-2019, 10:56 AM
I am so unhappy. The dynamixel-workbench will no longer compile, which make the arm :confused: dead. I hope they fix it, not sure how to get
one of there programmers to look at what the hell he is doing? The code was working an compiled last week, so.....

04-15-2019, 02:52 PM
What does not compile? And Where? i.e. is there an issue building for Arduino stuff for the OpenCR board or a problem with ROS builds?

Again I would probably first post up on Robotis Forum to get their attention: http://en.robotis.com/service/forum.php
With as much information as possible to localize the issue. This will get the attention of their main forum person @willson

Then depending on what parts are not working, I would post an issue up on the Robotis Github project

And to get the attention of their developers, Probably one or more of the following:

Good luck!


04-15-2019, 03:39 PM
Hum, that last link may be useful, thank you.

04-15-2019, 08:59 PM
God knows what happened, but I rebuilt Ubuntu and the ROS packages and everything is Okay now :o
This was easier than running all them bug reports. (Note. Found if you are playing with the End Effectors/Grippers
the servo can rotate around 180, you can just swing it back but it messes up slave/master operations and if you don't notice it,
everything runs but the grippers can not sync so they just don't operate.)

05-10-2019, 08:30 AM
Sweet! Got the pick and place example to work. It would seem there was a typo, on there web page.
On section, after launching the arm initialization routine, they use this command line to launch the
tags ($ open_manipulator_ar_markers ar_pose.launch camera_model:=raspicam user_marker_size:=3.0)
It should be: $ roslaunch open_manipulator_ar_markers ar_pose.launch camera_model:=realsense_d435 user_marker_size:=3.0
This works for the D435 camera and the OpenManipulator-x.
And of course the RVIZ launcher is just chuck full of rpi_camera code, oh dear.:confused:
I will try to contract the webpage maintainer.
(Note. I think it worked, it's fixed already)

06-21-2019, 12:01 PM
The Intel RGB camera stopped working, it turns out the dd_dynamic_reconfigure came up missing in the install instructions some place along the way. So I used github to download the source and all is well with the D435 camera.:wink:

07-01-2019, 07:06 AM
Someone pointed out this Open_manipulator_6dof_application. https://github.com/zang09/open_manipulator_6dof_application
I have got to try this out.

03-01-2020, 10:13 AM
I Love this robot arm, I Have two with plates and one on a tb3 waffle which is being upgraded to a PI4, woot!. It is a great way to Learn the ins and outs of robotic arms with ROS industrial. I do so wish it was a 6 degree of freedom arm over a 5 but it can be modded as I noted above. :wink:

03-01-2020, 02:28 PM
Based on your experience, do you see any point in getting the $150 base plate when it can be mounted on a TB3 Waffle Plate at 1/10 the cost? I am trying to save some money. I guess one needs to put a heavy weight on the end side of a waffle plate to prevent the arm from falling. What is the best camera for this arm? Is the one for the Pi sufficiently good enough?

03-21-2020, 08:26 AM
I finally put a manipulator onto my waffle-pi, and it works yea!! :tongue: