PDA

View Full Version : [News/Announcement] Turtlebot3 with Openmanipulator



LloydF
01-22-2019, 06:22 PM
It seem it is being renamed the Openmanipulator-x now.
http://emanual.robotis.com/docs/en/platform/openmanipulator_x/overview/

Tommy_T
01-22-2019, 10:18 PM
looks like hours of entertainment

LloydF
01-29-2019, 08:56 AM
LOL. It is not even here yet and I am having issues.
I tried to update a OpenCR board and now I have two OPenCR bricks.:confused:
Sigh looks like hours of entertainment, starts now.

KurtEck
01-29-2019, 09:29 AM
I have not done anything with mine for a few weeks now. Been busy with Puppy and with the Teensy 4 Alpha board.

Sometimes when I had issues iwth OpenCR board, I need to revert back to using the RPI (or UP) board to reprogram the board with current default firmware, before I could get it to talk again on Arduino...

LloydF
01-30-2019, 05:45 AM
:o Thank you. I found page 248 in the book were you press the reset and switch 2 which forces the boot-loader to run, yea!
That really had me thinking I bricked my boards when I noticed, I was not the only one with the same issue, so I re-read the BOOK and
lo and behold there it was, and the only place I have ever seen mention the use of switch 2, so yea again!!

KurtEck
01-30-2019, 08:53 AM
Glad that worked - Just in FYI - It is also in their e-manual...
http://emanual.robotis.com/docs/en/parts/controller/opencr10/#firmware-recovery-mode

LloydF
01-30-2019, 11:48 AM
Well with that out of the way it's back to waiting for a package :tongue:.
Look at the http://www.robotis.us/ site they have a frame set and a heavy base plate for the manipulator.

LloydF
02-01-2019, 04:31 PM
744374447445
Here it is. I downloaded the build instructions, as this one comes with no instructions, but useful links :wink:
There Disclaimer really needs to be more visible. i.e Base plate is sold separately like the power supply and a controller .
7446
The 5 Dynamixel's XM430-W350-T's come with ID's set to 11 through 15, maybe a hour and the hardware is done.
I would install it on my turetlebot3 waffle but I must play with it, before going mobile.

LloydF
02-11-2019, 12:14 PM
7453
The default configuration for the manipulator is on the u2d2 or a USB serial connection, and it works really well.
They have a direct link to some STL files for 3-D printers, so I printed some motor covers to round out the sharp corners and looks more robust some how :o.
746374647465
With a edit to the launch file the OpenCR Board runs the OpenManipulator. :cool:

LloydF
03-09-2019, 05:30 PM
I am happy to report that I have been able to get everything working, with the exception of the RC100 joystick with the OpenManipuiator. It should work but hum:confused: I am still working on that one. I kept loading the OpenCR chain instead of:
Go to Examples → OpenCR → 10.Etc → usb_to_dxl on Arduino IDE for OpenCR. Was making me crazy.:genmad:
It looks like there doing some good stuff with ROS Industrial for the OpenCR Board, Yea!
http://emanual.robotis.com/docs/en/platform/openmanipulator_x/ros_applications/#master-slave

LloydF
04-15-2019, 11:56 AM
I am so unhappy. The dynamixel-workbench will no longer compile, which make the arm :confused: dead. I hope they fix it, not sure how to get
one of there programmers to look at what the hell he is doing? The code was working an compiled last week, so.....

KurtEck
04-15-2019, 03:52 PM
What does not compile? And Where? i.e. is there an issue building for Arduino stuff for the OpenCR board or a problem with ROS builds?

Again I would probably first post up on Robotis Forum to get their attention: http://en.robotis.com/service/forum.php
With as much information as possible to localize the issue. This will get the attention of their main forum person @willson

Then depending on what parts are not working, I would post an issue up on the Robotis Github project

And to get the attention of their developers, Probably one or more of the following:
https://github.com/ROBOTIS-GIT/OpenCR/issues
https://github.com/ROBOTIS-GIT/turtlebot3/issues
https://github.com/ROBOTIS-GIT/DynamixelSDK/issues
...

Good luck!

Kurt

LloydF
04-15-2019, 04:39 PM
Hum, that last link may be useful, thank you.

LloydF
04-15-2019, 09:59 PM
God knows what happened, but I rebuilt Ubuntu and the ROS packages and everything is Okay now :o
This was easier than running all them bug reports. (Note. Found if you are playing with the End Effectors/Grippers
the servo can rotate around 180, you can just swing it back but it messes up slave/master operations and if you don't notice it,
everything runs but the grippers can not sync so they just don't operate.)

LloydF
05-10-2019, 09:30 AM
Sweet! Got the pick and place example to work. It would seem there was a typo, on there web page.
On section 9.1.3.3, after launching the arm initialization routine, they use this command line to launch the
tags ($ open_manipulator_ar_markers ar_pose.launch camera_model:=raspicam user_marker_size:=3.0)
It should be: $ roslaunch open_manipulator_ar_markers ar_pose.launch camera_model:=realsense_d435 user_marker_size:=3.0
This works for the D435 camera and the OpenManipulator-x.
And of course the RVIZ launcher is just chuck full of rpi_camera code, oh dear.:confused:
I will try to contract the webpage maintainer.
(Note. I think it worked, it's fixed already)

LloydF
06-21-2019, 01:01 PM
The Intel RGB camera stopped working, it turns out the dd_dynamic_reconfigure came up missing in the install instructions some place along the way. So I used github to download the source and all is well with the D435 camera.:wink:
https://github.com/ros/dynamic_reconfigure

LloydF
07-01-2019, 08:06 AM
Someone pointed out this Open_manipulator_6dof_application. https://github.com/zang09/open_manipulator_6dof_application
I have got to try this out.