PDA

View Full Version : [Question(s)] 1 hexabot leg not responding (Phoenix Code)



quarkburger
03-08-2019, 11:21 PM
I have just put together a PhantomX AX Mark III hexapod and installed the Phoenix Code from
https://github.com/KurtE/Phantom_Phoenix

When I run the Phoenix code it responds to the controller and I can use the left joystick to walk etc. The problem is my left front coxa servo does not respond. I know it's hooked up correctly because all servos respond correctly when I run the HexapodTest sketch.

The only change I made to the code was to change the DEFAULT_GAIT_SPEED in Hex_Cfg.h to 40 for my AX-18a servos. I had this issue before and after this change.

When it's powered I can move the left front coxa by hand. It resists a little, but not much. Like it would during the HexapodTest when commanded to relax. All other servos are rigid.

I also tried commanding each leg individually in single leg mode. All legs work fine except again, the left front coxa.

Thank you for any help you can provide. I will continue reading through the code to see if I can figure anything out.

quarkburger
03-08-2019, 11:44 PM
I found the problem...

In Hex_Cfg.h there is:
#ifdef OPT_CHECK_SERVO_RESET // Try to find single servo that reset it's ID...
#define cLFCoxaPin 19 //Front Left leg Hip Horizontal - Avoid servo 1
#else
#define cLFCoxaPin 1 //Front Left leg Hip Horizontal
#endif

I just had to comment out where OPT_CHECK_SERVO_RESET was defined :)