View Full Version : [Question(s)] PhantomX Reactor -> USB2AX -> Arm Link ->Processing 3 -> Windows 10 (is this possible?)

08-27-2021, 11:57 PM
A friend gifted me a Reactor Arm with 8 servos.

I got the USB2AX driver installed under Windows 10 (COM4)

Using RoboPlus 1 Dynamixel Wizard, I can see the COM4 working since it updates the encoder positions if I move joints by hand.

I installed Processing3 and the G4P and video libraries.
Then I downloaded ArmLink (https://github.com/Interbotix/ArmLinkSoftware).
You have to change all instance of G4P.WARNING in the source code to G4P.WARN_MESSAGE
and then it will run.

It fails to talk to robot when you click Connect on COM4.
I get the same verifyPacket Error: No Header! error as this guy:

looking for insight.....

09-02-2021, 08:27 AM
Sorry, did not see this messages until yesterday. Not sure if it was moderated until then.

There are very few of us up on this forum these days, and I am not sure I can help much, as I no longer have an arm setup, never tried the Arm Link stuff and have never used processing.

Unfortunately it looks like the library has not been touched in probably at least 5 years, is in an archived state and the developer of it, I am pretty sure has not worked there in a long time.

It looks like the code was developed for Processing 2, don't know how much of a difference this makes.

Sorry I am not a help here.