View Full Version : Sabertooth 2x5 R/C issue

10-12-2008, 11:08 AM
Hey all. I recently purchased the titular motor controller from Trossen, but there was a gap between when I bought it and when I actually tried to use. Woe is me that I should run into trouble. I simply cannot make in function correctly, and I am looking for something I may have overlooked.

- First thing is first. When the board came to me, the ground wire from the flip channel had come loose from it's soldering point. However I didn't fret because I don't really need the flip channel.

- I'm using the Arduino as the microcontroller because it's generally easy and problem free. It's wired to a little PCB with some servo header pins on it which the Sabertooth's pigtails plug into. I know that the problem is not on the end of the code because I can plug servos into these headers and they work just fine.

- A setup tutorial for the board suggested that if I'm powering my microcontroller from a different source, that I cut the +v wires on the pigtails (well, pull them out of the header, but honestly, how would you get them back -in- the headers?). These are apparently BEC pins supplying 6v to the microcontroller, which I don't need.

- The following dip switch settings are in place. Mind you, the switches for the R/C version are different from the other version: Independant Control, Disable exponential, non-lithium mode, digital flip mode, enable autocalibrate, disable timeout.

-And obviously, the battery and motors are hooked up to the terminals! 6 AAs, which is what the motors I'm trying to power now were powered with before. And they've got juice.

And still, even though I get a blue light (glowing brightly, which I think means everything is gravy) and I can control a servo from the same pwm pins, I cannot make the motor controller work. Any suggestions, or am I screwed?

10-12-2008, 12:17 PM
I've had to repair my 2x10RC a couple times. Use a magnifying glass or microscope and make sure that there's no shorted wire strands down where the servo wires go into the board. Also make sure that they're stress relieved straight up so they don't fall down and short.

My more permanent solution is done but untested, and that was to use a toothpick and some hot glue to separate them after I tore the board apart and resoldered them [for the third time]...

10-12-2008, 12:35 PM
Well, part of the problem with that is that there is a heatsink plate glued to the underside of the board and I can't really take a look at the underside of the thing, nor resolder lose wires should they break off.

10-12-2008, 01:01 PM
Those wires are very flimsy to say the least, My saber tooth 2 x 10 is a much better choice than the 2x5, I have two of each and the 10 is far better with it's terminal blocks for the wiring. I like you have to re-solder those cables as I am NOT happy with them.

10-12-2008, 01:20 PM
Actually, it's not really "glued" - it's being held down by hardened heat paste. Trust me - I've had mine apart many times. ;) It can be gently pried apart.

10-12-2008, 04:35 PM
Try using software driven PWM?

10-13-2008, 04:39 AM
Tyb, you fraud, you only knew that cause I told you :P

But yeah, problem solved... kind of. You probably know that the atmega has two 16 timers on it that can be used for hardware pwm on pins 1 and 2 port B (pins 9 and 10 on the arduino). I was using this, and it was not working, but when I used software pwm (manually switching between high and low with a software timer) it worked! Don't know why though, as I reckon hardware pwm is more reliable than the software variety.

Anyway, thank you for the replies of advice! (And in all fairness, Tyb -did- suggest that I try it out on a receiver, where I found out that it was indeed not a faulty board)