View Full Version : Bricked XBee [Sigh]

12-14-2008, 04:45 PM
Here's what I sent Digi's support. See if anyone here has any notions...

I had it responding fine in AT command mode. I wrote a PAN to it using the Digi X-CTU app, and then ...
Nothing. Error from the X-CTU and now it's not responding to AT commands anymore.
I put a pushbutton to ground on the RST pin. X-CTU was able to detect my hitting the reset switch on a
I put my good matching XBee on and did a read from it. XB24-B Zigbee Router/End Device AT Version 1220.
So I put the bricked one back on

Unable to communicate with modem
Pull RST low for a couple seconds, and the Info window disappears just like it says it will.
I see data go to and from the device a few times (RX/TX lights on level matcher flash) X-CTU reports
"Resetting AT Commands..."
Comes back a bit later and says "Unable to find configuration file for modem (firmware version ). Use
'Download new versions" button to check the web for newer versions
If I do a "Read" from a fresh boot of X-CTU, it displays "Entering Command Mode", then pops up the info
window. I hit the reset, it gets some data from the modem, the info box vanishes like it should, then
"Failed to enter command mode
Unable to read Version (ATVR)
Detected baud rate difference.
Make sure PC and modem baud rate is set correctly
Read parameters..Failed." I have tried every possible baudrate/parity combination.
Any advice?

12-14-2008, 05:16 PM
Apparently there is a way to restore factory defaults:

Have you tried this?

12-14-2008, 05:23 PM
Notice my post earlier in the second thread - and tried everything in the first as well..

I'm going to name it "Eric"

"No, Eric the Half-Bee. He had an accident..."

Half a bee, philosophically, must, ipso facto, half not be.

But half the bee
has got to be,
vis a vis
its entity - do you see?

But can a bee
be said to be
or not to be
an entire bee
when half the bee
is not a bee
due to some ancient injury?


La dee dee, 1 2 3,
Eric the half a bee.
A B C D E F G,
Eric the half a bee.

Is this retched demi-bee,
half asleep upon my knee,
some freak from a menagerie?
No! It's Eric the half a bee.

Fiddle dee dum,
Fiddle dee dee,
Eric the half bee.

Ho ho ho,
Tee hee hee,
Eric the half a bee.

I love this hive employee-ee-ee
[with buzzing in background]
bisected accidentally
one summer afternoon by me
I love him carnally.

He loves him carnally... [together]

The end
[Monty Python]

12-14-2008, 06:18 PM
Woohoo! Eric is a whole bee!

Under PC Settings, I needed to change it to API mode, then write the AT firmware back to it. Now I have AT commands again. Woot!

12-14-2008, 06:31 PM
Whew! I am glad I am whole again. :happy:

12-14-2008, 06:35 PM
Eric the 'alf a Poster? Naw, I think you just never had some tragic ancient....injury.

12-14-2008, 07:09 PM
I think this is due to you not using my awesomely simple level converter. :D

12-14-2008, 07:20 PM
I know you're kidding, but...
Actually - had nothing to do with it, since I wasn't using EITHER. I was using a Sparkfun TTL->RS232, and everything was at 3.3v all the way through. Had to do with a bad flash...

12-14-2008, 08:05 PM
Better to Bee than not two B .. or would that Bee Tube bee??:rolleyes:

Glad you found the problem..

12-14-2008, 08:15 PM

What mode are you guys running in for a straight serial link?

I've got one set as a Coordinator 2.5 AT, and the other set as a Router/Endpoint 2.5 - I know they can see each other, I do an ATND on the coordinator and get the node dump correct from the end-point, but I'm not getting data from the end-point back to the coordinator.

(I'm sending a string every few seconds from an Arduino back to the PC, PC is the Coordinator, Arduino is the Endpoint)

It's not the level board either - I am getting node info broadcast, and I've tried it with the board and with a simple divider similar to what Tybs posted...

[edit] Err - guess it could be. The node identifier would be independant of the serial device attached, since it's querying the XBee, not the Arduino. . .

12-14-2008, 08:35 PM
Got it working - must have been funky wiring.

Still interested to know what you guys are using mode-wise...

12-14-2008, 08:35 PM
I made very few changes in the default configuration of my XBee's. Using the Sparkfun Xbee explorer and the X-CTU software, I set the destination address low (DL) and the source address (MY) to the serial numbers of the modules. Reduced the power level (PL) and set the baud rate up a little. For my purposes, I didn't need to go any farther. They hook up good and work fine.

12-14-2008, 08:38 PM
Oh yeah.. I updated the version to 10CD.

12-14-2008, 08:55 PM
I'm doing pretty much the same as gdubb for my testing.

12-14-2008, 09:23 PM
Doing it that way, isn't it unidirectional, or do you set the opposite source and destination on the other unit?

12-14-2008, 09:47 PM
I'm also using an Xbee Explorer with the installed Xbee set for ZNET 2.5 Coordinator AT. The Xbee on the Arduino is setfor ZNET 2.5 Endpoint AT. I simply specified a PAN and didn't specify a destination address for either module. The Entire PAN (only 2 modules) will see the traffic but it works in both directions quite well.

12-14-2008, 09:57 PM
Nod. Ok - that's what I'm doing - although I did name the nodes.

12-14-2008, 09:59 PM
Oh I forgot that I named the nodes as well.

12-14-2008, 10:02 PM
Little stuff... ;)

12-14-2008, 10:07 PM
I set the oposites as the source and destination. It's bi directional and locked to each other.

12-14-2008, 10:15 PM
Gotcha. I kinda thought that would be the answer to that one.

Hmm. Decisions... ;)

12-14-2008, 10:25 PM
Incidentally: I sent "!!! It's colder than reindeer balls !!!" 15,623 from the Arduino to the PC and "!!! sllab reednier naht redloc s'tI" back from the PC to the Arduino in response. I had one dropped packet, but error recover recovered it, looking at the timestamps in my logs.

Granted it's only ~75ft, but one is sitting in the kitchen (and I had the microwave running for several minutes which also nukes my Bluetooth anywhere in 30ft) and the other is in the lab, a couple feet from two wireless routers and a bluetooth repeater.

Something to be said for clean power? ;)

12-14-2008, 10:32 PM
On my front porch it's 4 Deg.F right now...Reindeer got nuthin on us...Bwaaahaaha

So that's what it looks like in German....

12-27-2008, 11:39 PM
I need to update my answer. Everything was working fine without specifying addresses but it turned out to be slow and I was dropping the occasional packet. I set the destination addresses and saw a massive improvement in performance.

I also added some recovery stuff to my serial software as well. The robot echos the data stream coming from the computer. If they don't match then the computer resends the data until they do.

06-15-2009, 01:14 AM
This worked for me when the reset trick refused to.

It is possible when using the USB board. You just have to go about it in a different manner.
1. Take the module out of the interface board.
2. Connect the interface board to the computer.
3. Open X-CTU
4. Go to "Modem Configuration"
5. Put a check in the "Always update firmware" box
6. Select proper modem from drop down menu,
7. Select proper function set and firmware version
from drop down menus.
8. Click on the "Write" button. After a few seconds of
trying to read the modem, you will get an Info box
that says Action Needed. At this point, CAREFULLY
insert the module into the interface board.
9. You may get the info box again a short while after,
just use the reset button on the interface board.

This should get you back up and running.

It can take a couple of tries but it worked for me.

If you just have a breakout board make sure you hook up the Xbee like this:


It won't work with just Dout and Din connected. Otherwise follow the instructions above.

06-15-2009, 10:49 AM
Welcome to the forum, and thanks for that follow-up!