View Full Version : [Question(s)] PX5000 problems

01-30-2009, 10:42 AM
Hello folks,

I have just recently started using my newly acquired picoITX PX5000EG on my tri-track chassis. I have run into multiple issues with this board and was wondering if anyone else here has had similar experience.

1) Initially the board's onboard CMOS battery was completely dead so it would never save any BIOS changes or date/time after i would unplug it from the power source. Hence, I bought and replaced the battery.

2) Even with the new battery, when I unplug the power cord from the board and plug it back hours later, the system time seems to completely forget that a couple hours have elapsed. I.e. if I switch off the power at 9 Am and plug it back on at 11 am, it would think that its still 9 AM.

3) Yesterday after I went in to the BIOS to set the date/time again and after saving and exiting, the screen would get stuck just after the initial splash screen, displaying a bunch of IRQs and other things. It would just sit there frozen. I had to push the power button for 4 secs to turn it off. This would happen everytime untill i pulled the power supply, waited for 5 mins and then plugged it back on. Everything was fine from here on, unless I went in to the BIOS setup and exited even without changing any settings. Repeating the above was the only way to move forward.

4) Once I am in Windows, once I hit the shutdown button, it would shutdown just fine, untill last evening, when it would just keep restarting instead. This kept happening until I unplugged the power, waited for 10-15 mins, plugged it back in, got the CMOS Checksum error (as if this is the first time I am switching on the mobo), hit the F1 button to continue. After that, the restart issues went away. This suggests that its not a Windows issue, but more to do with the board's BIOS since I didnt change anyting in Windows to create or fix the problems.

These things are just happening randonly. I have tried even after disconnecting all the USB devices (wifi adapter and Phidgets motorcontroller HC), no differences. I have already tried to reset the CMOS by using the jumper method as mentioned in the manual.

BIOS version is 1.04 on the board, whereas the official download site says that the latest BIOS is 1.03.

Anybody seen anything similar?

01-30-2009, 10:46 AM
Maybe roll back the BIOs revision, if for some reason its showing newer than available. Pretty sure you can back up your current version anyway, but its worth a try.

These all sound related to a BIOS/Cmos issue.

01-30-2009, 11:10 AM
Are you using the BIOS defaults? Also did you check the bad battery with a meter?

01-30-2009, 11:20 AM
Thanks Tyb and Jes.

@Tyb: Yes, I was also wondering if rolling back the BIOS to 1.03 would help. The problem is, I cant find any documentation on how to flash/backup the BIOS on the pico. Also, I dont wanna risk bricking the pico entirely :P hehe

@jes: Yes, I loaded the BIOS default last evening and even after that, the issues persisted. I checked the original CMOS battery with a multi-meter and it showed absolutely 0 volts!

01-30-2009, 11:27 AM
Oooh that's not good. Try unplugging the board from power and remove the battery. Put an ammeter between the battery and the socket and measure the current being pulled from the battery then plug power back in while testing the current. The board should only pull power from the battery when the main power is disconnected. You may see a very tiny amount of current with the board plugged up but it will be miniscule (a micro amp or so).

My main thought is that the BIOS chip or Real Time Clock is damaged and it's pulling too much current from the battery when the power is disconnected.

Also is this a CR2032 battery?

Edit: Here is the datasheet for the 2032 battery. It's rated for 225mAH.

01-30-2009, 11:41 AM
Thanks jes. The RTC being a bad boy was the first thought that came into my mind last evening. I will try to measure the current over the weekend as you have suggested (fun weekend yayy!!). Yes, the battery is a CR2032, bought from The Source by Circuit City (here in Canada). The old battery being in complete 0V is definitely something that I am seeing for the first time.

Whats weird is that under normal circumstances, either the BIOS completely forgets the time/date or remembers it (you know...0 or 1) but in my case, it kinda goes in a coma and the time freezes since the last time the power was unplugged from the board.

01-30-2009, 11:44 AM
Yeah 0V is weird and makes me think that it dumped a large amount of current quickly, this my speculation above.

01-30-2009, 11:38 PM
Came back home and switched on the picoITX and the clock showed the time from the morning (7:45 AM to be precise) when I had powered it down before going to work and unplugged it from the wall. So basically the RTC just sorta freezes when its unplugged? It doesnt seem to take into account that a battery is onboard? Or maybe the new battery that I put in is already drained out completely? Anyways, I will check the voltage/current draw from it tomorrow morning and post back. Thanks all!

01-31-2009, 01:48 AM
If it reads the shutdown time, the CMOS has got to be alive, which suggests your battery won't be dead.

If your battery were dead, it'd go back to its date/time of manufacture or start of epoc, but not shutdown time...

01-31-2009, 08:16 PM
Ok, just turned on my pico once again, and the time shows up from last night (11:46 PM, 30th January, 2009) when I had shutdown XP and unplugged the cord from the picoPSU. So, as Adrenalynn said, the CMOS must be alive, but the problem is elsewhere. Any other ideas anyone?

01-31-2009, 08:54 PM
Have you flashed the BIOS to the previous revision yet?

This sounds like quirky BIOS behavior to me.

01-31-2009, 09:05 PM
You know, I remember weird bios issues with the RTC on some miniITX. Have you tried going forward or even backward in your bios flash?

Sorry - didn't see your post lurking there all by itself on a new page, Tybs.

01-31-2009, 09:23 PM
Thanks Tybs and Adrenalynn. I have not touched the BIOS yet. The board came with 1.04 version and the official one on VIA's website is 1.03. I guess I am kinda scared in doing that since I dont see any official documentation on how to backup or flash the BIOS from Windows.

I do not have an external USB floppy drive etc to flash the BIOS either. Tybs, do you have experience in flashing or backing up the stock BIOS on the pico?

01-31-2009, 09:39 PM
Its just like any other motherboard. Get a DOS boot disk on one floppy, and the flash utility and 1.03 BIOS on the other. You should see an option to make a backup of the current BIOS in the flash utility, but both of my pico boards (which work fine) are running 1.03. Sounds like your board is running a beta version, so I'd definitely recommend stepping down to 1.03 even if you can't backup your current.

01-31-2009, 11:29 PM
Very surprising that the DOS and the Windows based BIOS flash utilities are both beta!


One would think that VIA had done enough testing in the last two years to get them out of BETA.

I will give this a shot only once I get a hold of a USB floppy drive somehow.

01-31-2009, 11:40 PM
Well, if they have a Windows XP based version you wouldn't need a USB floppy.

02-01-2009, 12:42 AM
Ok, just downloaded the 1.03 version BIOS and the windows flash utility from VIA's website. Backed up the existing 1.04 version of BIOS from the tool and then flashed the 1.03 version. The flash was painless and quick. Rebooted the machine and it booted up just fine. Re-checked the BIOS version and now the tool shows 1.03 as expected.

Shutdown the machine (at 12:21 AM EST) and disconnected the power cord for about 10 minutes. Reconnected the power cord, started the machines off and the time still shows up as 12:21 AM...when the machine was powered down. So essentially, the BIOS flash does not seem to have helped. The fact that the last known time is shown means the onboard battery helps the system remember the time. I will dismantle the tri-track and reset using the CMOS jumpers tomorrow morning and see if that helps at all. Any other ideas?

02-01-2009, 05:40 PM
Nope, just dismantled the entire tri-track chassis to get to the pico, reset the RTC RAM using the pink jumper onboard, set it back to normal position thereafter. Then started the system, obviously, "Checksum error" appeared, went in to the BIOS and set the date time. Saved and exited and then powered down the system.

Waited for 5 minutes and went back in again and the time still shows from 5 minutes ago. So that was a no-go. Seems like the RTC just stops ticking when the system is not connected to the main power supply.

EDIT: Oh and I just popped off the CMOS battery and the voltage reads 2.65V. Is that normal? How does it pop down from 3V to 2.65V in just a week or so? I think something is sucking out the juice from the battery like crazy and hence the last one was at 0V and this one is already so down and thats probably why the RTC is not running whilethe power is not connected.

02-01-2009, 06:13 PM
Did you measure the current? Be sure to measure it while it's loaded and check the battery voltage at the same time.

02-01-2009, 07:11 PM
On a closer look, there seems to be some residue left on the CMOS battery holder from the past. Is it possible that a battery might have leaked in the past, damaging/shorting some pins thereabouts and causing an anomaly like this?