View Full Version : [Question(s)] PX5000EG boot-up malfunction

02-14-2009, 02:43 PM
Dear All,
I have recently procured a PX5000EG mainboard from VIA and GP-87 DCDC converter from Serener. Connected them, fitted a PS2 keyboard and a CRT display from VGA port of the board. With no an IDE device, or a USB device, powered on the system to see the BIOS screen as a start, and the board does not seem functioning.

The symptoms are: the board draws 520mA from the supply at 12V and when powered off from the front panel switch, the current drops only a few 10mAmps (although I have measured the 3V3, 5V0 and 12V rails on the connector as power-off reading small values as 1-2V).
When in reset (i.e. as long as I press the reset switch have connected on the front-panel connector) , it draws approximately 320mA, and during all the time, the CRT does display nothing!
Could anyone tell me where did the things go wrong? Do I miss something?
Appreciations in advance for your helps.


02-14-2009, 03:04 PM
You're not running from battery, right? That power supply is not intended for battery operation. To quote:

"Input Voltage is strictly required between 11.4v ~ 12.6v. Not suitable for use in automotive applications unless used in conjunction with an additional 12v power regulator."

A fully charged battery is outside of that voltage range.

Beyond that - have you tried Via's forum?

Welcome to the forum!

02-14-2009, 04:23 PM
Appreciations for your wellcome and helping effort. Yes I have sent a post to Via forum too.

I have connected the Serener directly to a stable lab supply (an Agilent make), adjested to 12.0V.
Besides the non-responsive mainboard, another weird thing is, as I power-off the module from front panel connector header on the board, the Serener goes to blue LED from RED which, I assumeto indicate the power-off state of the supply, but the current drawn from the Agilent does drops only 10-20mA (from 520mA @ 12V to ~500mA).
Did I miss something in the procedure:
1. Connect VGA, PS2,
2. Connect PSU,
3. Power-ON

02-14-2009, 04:26 PM
I don't know how much help we can all be. We mostly do the robotics thang around these parts, which requires battery power, so we all use a different power supply.

A common issue is grounding around these parts. so I'd check your ground. Although if it's pulling half an amp, your ground should be pretty good.

Have you read your 12v after it leaves the power supply and into the load (motherboard)?

02-14-2009, 04:46 PM
Which supply you use for that board?
I have checked the ground: it is connected all the way between the lab supply to the board's ground.
I read the 12V on the connector on the board in the OFF state, the 12V reads something around ~3V and interestingly, the current which reads around 500mA drawn from the supply droops fastly to the "real" power-off current which is 70mA as I put the probes of the voltmeter to the GND and 12V pin. But if do not read that voltage by the multimeter, the 500mA current suspends like forever. I could not realize from which rail the load draws that amount of current!

Thanks anyway. I assume, something destructive happened to the board on the way between the vendor and home. I will continue to determine the malfunction though.

02-14-2009, 04:50 PM
We usually use one of the wide-range supplies.

I beleve there's a speaker port on that board, isn't there? Have you plugged one in to listen for POST beeps? Without POST information, it's hard to tell if it's something like RAM or display issues.

02-15-2009, 12:28 PM
Dear Adrenalynn,
Your recommendation helped a lot. It has solved the problem. Thanks a lot.
I could not find a speaker to beep off-the shelf anyway, but have looked to the POST actions/reactions of the AwardBIOS. It seems to be looped and locked at RAM test, and yes there is none on my board! Immediately I procured a 1GB SODIMM, socketed it and have seen the nice bootup screen. Appreciations again.
The bizarre current behavior is keeping to occur, but I assume it has something to do with sleep mode of the mainboard.