View Full Version : trouble programming xbee with x-ctu

09-25-2009, 06:02 AM
hi. i have two x bee modules and one xbee usb explorer.The modules are XBee 2.4 GHZ 1mW Communication Module ---> http://www.trossenrobotics.com/store/p/5200-XBee-1mW-Communication-Module.aspx

The firmware version is 1084

i wanted to program the xbee, using the x-ctu software.but i am having problems with the commands in the terminal window of x-ctu

i want to use the D0 pin of the xbee module as an adc input and i will have to set it's value to 2. the command for this would be

ATD0 2but when i enter this, every time the x-ctu softwares gives the response "ERROR"

then i also tried reading the default value for D0 with the command

ATD0but still it gives "ERROR"

but i can use the "ATDL" or "ATMY" and "ATWR" commands for reading/changing the destination/source address.

so im totally out of clue here about what to do.... :-[

09-25-2009, 09:14 AM
Hi I am playing with Xbees right now as well and I had one plugged into my USB Digi card, so I tried it and it failed as well. When I looked in the manual, it said something like minimum version 1.x.A0. So I am guesing to use the IO lines you may need to go to the A series of images. Something like 10A4. I did not reflash my module so I can not say for sure

09-27-2009, 11:59 AM
i got the xbee to work.it just had an old firmware and i updated the firmware and it's working fine.