View Full Version : Dynamixel lighting?

11-13-2009, 08:08 PM
I have a dynamixel AX-12+ that sometimes doesn't move where I tell it to. It will just stop and the CM-5's TXD button and the light on the dynamixel will light. This happens even in the demo examples. Please help! Is there a way to fix this problem? Have others had this problem?

11-14-2009, 07:07 AM
You did not supply enough information.

Which AX-12 is causing the problem? ID #
Are you building a one of the Bioloid robots? If so, which one.
What is the name of the Demo example that you're trying to execute?
Are you using the robot terminal, behavior programmer, or motion editor?

When an AX-12 LED lights, it's usually an alarm indicator. Have you modified the AX-12 control table in any way?

Have you tried to reset the AX-12? If you reset the AX-12 did you remember to set the ID back to the original ID?

11-14-2009, 09:49 AM
Most often these are wire problems. Replace the wire to that servo.

11-14-2009, 12:32 PM
Sorry for not supplying enough info.

The AX-12+ in question is ID# 15, but the servo right after it in the daisy chain configuration also somethimes has problems. That ID# is 17.

I am using the King Spider with the demo example from the book. So I am using the Behavior Control Program and the Motion Editor.

I have not edited the AX-12+ control table in the least or reset them. (To be honest I have been kindof nervous to. I don't really have enough experiance.) :o

I tried fixing the wire by replacing them but that didn't seem to help.

11-14-2009, 01:31 PM
If you hook up the individual servo to the CM-5 in manage mode, and try moving it via the Dynamixel manager, does that work?

11-14-2009, 02:49 PM
Andrew is right you should use manage mode to checkout what going on with the AX-12 but I leave the chain intact. When the LED lights you'll want to dump ID 15. That will show you all the register values. You might also try to "Ping" 15 as that should return any error codes due to out-of-whack voltage or torque.

11-20-2009, 03:01 PM
I am slightly confused. :confused: What do you mean by the "Dynamixal Manager?" I disassembled the Spider and tried the AX-12+'s seperatly and they worked great. I Thought that it was maybe my consruction. So now I built the Humanoid and am having some of the same issues. Except this time the one lighting up is ID 14!

I an not really sure on how to use the Robot Terminal and when given all of the info on it for the AX-12's I don't know what there supposed to be and how to correct them.

Thank you all!

11-20-2009, 03:27 PM
I'm in real trouble now! I was reading through the Robot Terminal directions in the manuel. I saw the reset command so I reset the AX-12's that were having problems, and now I can't run any programs without getting tons of error messages. :eek::robotsurprised:

11-20-2009, 03:55 PM
I think the reset command resets the ID #. So the CM-5 thinks there are several devices on the serial bus with the same ID #...

At this point your probably going to have to take the bot apart, and set each ID # manually. Sorry for the bad news.


Also, I think some of the problem might be the overheat issue. If you hold an AX-12 in a stress position for too long it goes into thermal shutdown.


11-20-2009, 03:56 PM
That may be due to them all now having an ID of 1 after the reset? I don't think the bus likes that. Try hooking up each individually and set the ID to the appropriate value using the Dynamixel Configurator program.

EDIT: Lol, looks like DB and I posted at the same moment.

11-20-2009, 04:27 PM
>> going to have to take the bot apart

Naw, you don't need to take it all apart. Just unplug each servo from the chain, one at a time, and reset the ID. No reason to go disassembling it. I change my servo ID's more frequently than my mind, and that's sayin' something. ;)

11-24-2009, 02:21 PM
Sorry its taken so long to get back the results. I have got the 3 ax-12's that need to get the ID's changed back but I can't find the program that you use. I have searched and searched for it. Could one of you upload it or is there somewhere I can download it?

Edit: I found the program from Robotis and am running it right now.

11-24-2009, 03:01 PM
The ID's are now reset to their original ID's. But I am still getting the same problem. The humanoid freezes up and I get an error message saying "ERROR:8100[0438:80]100 002 041 001" What does all this mean? I know that the error 8100 means. But what is all the rest of it?

11-27-2009, 12:14 PM
Am I the only one that has had this problem? It seems like every robot I build with this kit has a problem with on eof the motors. Any ideas?

11-28-2009, 12:26 AM
I'm sorry no one has gotten back to you. Not a lot of people are using the CM-5...A lot switched over to the arbotix.

Another forum that you may want to /may already be trying is robosavvy...I would post in both places if I were you.

Ok...a bit of research there says that it could be one of two things...the baud rate of the reset servos? Not sure about that one, and the other is to check for broken wires.

Quoting from robo savvy...

First of all, CHECK if YOUR current baud rate have the correct value

From the AX-12 manual, page 13.

Address 0x04 Baud Rate. Determines the communication speed. The computation is done by the following formula.
Speed (BPS) = 2000000 / (Address4 + 1)
Note A maximum Baud Rate error of 3% is within the tolerance of UART communication.
Caution The initial value of Baudrate is set to 1(1000000bps)

And IF this is YOUR problem... from the same manual, page 24, Example 8:

Changing the Baud Rate of a Dynamixel actuator to 1M bps

Hope this helps.


11-28-2009, 07:40 AM
I have no idea what ERROR:8100[0438:80]100 002 041 001 or which program is catching the error, behavior or motion editor?

@darkback2; it not the baud setting since the servos function for some period of time.

@dantaylor129; Like I said before, you need to query the servo when the problem shows up. Use manage mode on the CM-5 with the robot terminal program. First do a ping or a move anything to get a response packet. Then match the error code to one of the published codes in the AX-12 manual on page 15. Also do a dump! You should practice this first.

I suspect it's the overheating alarm (0100 | 0x04) since the Alarm LED and Alarm Shutdown registers (0x11 and 0x12) default to 0x04.

Anyway, once you figure out the cause you'll have a better chance of fixing it.

11-29-2009, 01:03 PM
The error message that I was getting was in the Behavior Control Program.

So when I'm in the Robot Terminal all of the motors are fixed and unmovable except for 14, 15, and 17. And they blink quite a bit. I can control them with the GO command sometimes but sometimes it is delayed for a bit, It will blink until I actually move it to its proper position, then it will stop blinking.

I am not getting any error messages in the Robot terminal. It just doesn't move sometimes.

I don't know how to do a DUMP...

11-29-2009, 06:29 PM

I don't use the CM-5 but if I remember correctly it returns a status packet after executing a "GO" command from manage mode. The status packet you want is the one that does NOT result in a move. That's the one with the error byte. Open the AX-12 and Bioloid manuals and read.

12-04-2009, 01:30 PM
When it does move I get this status packet:

-> [Dynamixel]:255 255 014 007 003 030 200 000 050 000 207 LEN:011(0X0B)
<- [Dynamixel]:255 255 014 002 000 239 LEN:006(0X06)

But when it doesn't move I don't get a status pack at all I get something like this:

[Err:RxD Timeout]
[Err:RxD Timeout]
Err ID:014(0X0E)
-> [Dynamixel]:255 255 014 007 003 030 200 000 050 000 207 LEN:011(0X0B)
No Data(Check ID, Operating Mode, Baud rate) LEN:000(0X00)

12-04-2009, 01:44 PM
You're getting timeouts. Check your cables.

12-04-2009, 01:51 PM
Is there a better way to wire the Humanoid? Do any of you have this problem? I think the problem is that the wires keep getting crushed by the plastic frame pieces. Especially in the Humanoid becuase of the motors being really close and the wires go between AX-12's. Is there a way to fix this? Or make the wiring more efficient?