View Full Version : [Question(s)] Trouble with CM-5 firmware for RoboPlus

01-24-2010, 04:07 PM
Has anyone else had this issue? I downloaded the RoboPlus software from Robotis, and used the Controller Firmware Management function to update my CM-5. It all seemed to be working well, and I was able to set IDs and control the attached AX-12s. But now, (a day and several reboots later) I can't get the RoboPlus Manager to see my CM-5. Strangely, the old Robot Terminal is able to receive data after the initial connection in Manage mode- this is what I get: {[CM-5:1.1963]} plus additional lines identifying the attached AX-12s. So apparently my firmware is not upgraded?

But if I try the RoboPlus Firmware Management again, that can't see the CM-5 either... I'm stumped.

01-25-2010, 11:48 AM
Just to rule this out, have you tried an uninstall/reinstall of the Roboplus software and/or tried it on another computer?

01-25-2010, 08:05 PM
No, that's a good idea. I don't have another good PC to try; also I have gotten it to connect only once or twice more, by various combinations of powering on/off the cm-5 and reattaching the serial cable. RoboPlus also reports it as firmware 1.1963 even right after the firmware update.

01-25-2010, 10:14 PM
OK, I think I've found the problem- a bad wire in the serial cable, right where it jacks into the CM-5. If I hold it just right, Roboplus can see and connect- but when I let go, it loses the connection. Guess I'll just have to crazy-glue my fingers on to the cable! (or perhaps i can buy just the DB-9 to 3 mm plug cable... ;)