View Full Version : Issue with Motors

02-13-2010, 12:21 AM

I am having an issue with one of two motosr purchased recently. The motors are the Hennkwell 7.2v gearhead motors.

I am using XBEE for serial communication on a roboticsconnection serializer. I configure both module to communicate at 19200.
I launched Putty and confirm that the their is serial communication. Now when i issue the "test" command to the serializer, i see "starting PWM test" on my putty console followed by a high pitch/frequence-like sound coming from the serializer ( is that normal?).

The problem i am seeing is that my left motor spins, but my right motor seems to have a difficult time dowing so. I tried turning that track manually and it is very difficult, while the left motor track that is working can relatively easily be turned manually. From that i can see there is nothing obstructing that right motor from spinning.

Any ideas what may be causing this?


02-13-2010, 01:28 AM
How much current do those motors draw? The H-Bridge on the Serializer is only 4amp max.

02-14-2010, 04:01 AM
Have you tested each motor individually? Is it possible to bypass the control circuitry and power the motors directly? What happens if you hook the left motor to the right input and vice versa?

If any or all of these things still give you different performance between motors, then you might need to take the right motor apart and lubricate it. If that doesn't fix it, then it is probably a hardware problem and you will need to return the motor.

And yes, that high pitched noise you hear is normal. It should vary with the speed you are running your motors at.

02-14-2010, 01:01 PM
Thanks for the responses, i was able to get this working. I think, as suggested by you all, it was power related and a bad wire connection on my part.

I took the motor apart, greased it and put it back together. Then when connecting directly to a 9.6v source, it worked fine. When connected to the controller, it either did not respond at all, or jumped slightly. When looking at the connection to the powersource, i relaize that probably the problem was that the plastic covering might have been inserted too far into the holes where you stick the wires in. I shaved a bit of the wire covering off and connected once more and seems to work.

Now i just have to try and get this thing to run in a straight line.

The new Serializer 3.0 has a dedicated power source connection for motors. I am not using that, but perhaps i should. Only problem is the documentation is not updated for the new 3.0 serializer as yet, so the it does not discuss this dedicated power source option, and i don't want to go sticking power sources there without more details first.

Thanks again!