View Full Version : HSR-5990TG moving too slow?

04-15-2010, 06:57 AM
I just bought a HSR-5990TG from trossen and hooked it up to see that the response time seems more like 1s / 60 degrees than the .17s no-load spec.


I'm driving it with a standard pulse signal, which I believe is OK even though it also accepts something called HMI. It responds correctly, it just takes a while to get where it's going.

Do I need to use HMI to configure it to full-speed mode?

A simple comparison with another servo on the same circuit worked fine.

thanks for the help!

04-15-2010, 10:13 AM
You're running it off of 6v I take it?

What are you using the drive the servo?

Shouldn't have to configure them, they run fine out of box generally.

04-15-2010, 11:49 AM
I've tried it at voltages between 6 and 7.1V. Some new behavior now...

For some moves, it goes fast, at what looks to be the rated speed. For other moves, it gives a short twitch, pauses for a half second, and then moves at about 60deg / sec to the destination. It always goes to the correct spot. It seems to move fast in the negative direction more than the positive. Some degrees always move fast, some don't. Very weird!

The pwm pulse looks good, between 600us to 2200us or so. 5V on the pwm, and about 20ms between pulses.

I'm controlling it with a pulse from an arduino using the standard servo library. I'm powering it separately, but connecting both of the grounds.

I've got the brown wire on the signal, middle on 6-7V, outside black on ground. I may have hooked it up backwards at one point, but that normally wouldn't kill a servo... hope this one isn't different.

I'm thinking I may have put it into some different mode where it's trying to give me position feedback or something. I read online that if you give it a 50us pulse it returns the position.

Thanks for the help, I'm all ears to some simple mistakes I'm making!

04-15-2010, 12:19 PM
What is the current capability of your PSU ? These servos do take a lot of current and can cause brownouts.

04-15-2010, 12:30 PM
I'll try some batteries. My PS is 5A capable, but I never saw more than 300mA being drawn. I'm just trying to move it without a load. thanks for the suggestion, I'll write back if it works.

04-15-2010, 12:54 PM
Might try a battery but if your PSU can source 5amp that shouldn't be a problem.

Try removing the 20ms low signal? The digital servos don't require it and normally don't have issue with it present, but it's worth a try.

04-15-2010, 03:29 PM
You guys were right! It was the battery!

Well, truth be told I never tried a battery, I just stuck a big capacitor (330uF) near the servo power and baddabing, it works great. The Power supply has plenty of amperage, it just couldn't deliver that amperage quickly enough.

Thanks so much for the fast replies! I will now attempt to not break any fingers with this thing :)