View Full Version : [Question(s)] Robard Instalation Problems

07-21-2010, 07:22 PM
I am currently trying Install Linux into my Roboard. I have currently run out of ideas in how to install. My first major attempt have tried fallowing debian installation PDF that used to be on http://www.roboard.com/download_ml.htm website. I fallowed the instructions and installed new debian kernel, when I load after installation I can only see the grub loader. I have tried many commands but could never get past the loader. I have tried Installing Ubuntu and have failed on that point. I have also tried installing XP fallowing the http://www.roboard.com/Files/RB-100/Install_%20XP_RB-100.pdf guide, this was unsuccessful. (Although it was fun learning how to remove the grub loader from the memory stick.) I have also tried 3 different memory sticks to eliminate that possibility. When I contacted Roboard support, they issued me a ghost file. I used Norton ghost to install the file into to the micro SD card. I verified that the files where on the SD card but the Roboard would not recognize the SD card. I am at a loss on what to do. Is there any ideas on what to do to solve this problem?

07-21-2010, 07:55 PM
Don't really have any pointers, except, have you seen the very detailed step-by-step install instructions in the tutorial section of this forum? There might be some extra information there.


07-21-2010, 08:11 PM
What size SD card are you using?

07-21-2010, 08:27 PM
I have tried a 4 GB, 8 GB and 16 GB micro SD. each from different manufacturers. The Install forum notes was very helpful to get to where I see the problem (they where the second ones I tried). When using Linux i can see the grub loader so I know the SD card can be read. its just that it hangs in the grub loader. I'm not the best with non-standard operating system Kernels, but the steps where fallowed precisely. Even the ghost file from the manufacture should of worked. I have been starting to wonder if there might be another problem? Or if its time to try another micro-controller? It has been almost a year of scratching my head, sending emails, and out sourcing computer techs. I like the board and its capabilities, just hate the first hurdle.

07-21-2010, 09:51 PM
You probably aren't going to have any luck with larger ones, I've never been able to get anything larger than a 2gb card to work. Try a 1 or 2gb card, the SD isn't really intended to be a storage device, rather just a boot drive.

07-21-2010, 10:02 PM
the debain ghost file I receved from Roboard was 4 GB's.

07-21-2010, 10:06 PM
That's weird, I know it's pretty picky on what type of cards it uses. Personally, I've not had luck with anything larger than 2gb. I can ask my contact at Roboard to weigh in on this tomorrow though.

07-21-2010, 10:07 PM
Thank you... I may have had trouble finding a supported model

10-05-2010, 05:48 PM
I gave up on the linux install and spent 2 months on the XP install... I don't know why it took me so long. The last 8 attempts where completed the same with the same data but only the last one succeeded.

The new install tutorial on roboard website was very helpful ( http://www.roboard.com/Files/RB-100/XP_RB100_Guide.zip )

While working on it I noticed that XP SP2 will not work with this installation. Out of my 5 tries with SP2 I found it hangs in the Location Setting window. Well more like it turns the USB off some point before that and you cant continue past that point. I did not have that problem with SP3.

Well I finally have something to work with now. Thanks everyone for your help.

10-05-2010, 05:57 PM
I was able to install XP onto a 8 GB SDHC card. So it is possible for XP. Roboard's website just says any capacity.

11-26-2010, 11:01 AM
I'm trying to install windows xp on my roboard 110, but when I boot from the usb stick, I select install xp step one, and it says inspecting hardware. Then it gives me an error saying:
"Line 9560 of the INF file \i386\txtsetup.sif is invalid. Setup cannot continue. Press any key to exit."
Anyone have any ideas? I tried a 16gb card yesterday, switched to a 2gb card to day, still same problem...

Edit: I tried without the sd card also, still the same error msg...

06-11-2011, 03:42 PM
I'm hoping to purchase a RoBoard soon. Yesterday I took an industrial board that uses the same Vortex86DX CPU and easily loaded two Linux distros on it. I have a USB CD drive that my old Toshiba Portege laptop could boot from. The Vortex boots from it too so that made installation simple for me.

I tried two Linux distros and they ran well for me:
ttylinux ut 486 ( http://minimalinux.org/ )
antiX base 486 ( http://antix.mepis.org/ )

I also installed antiX to a 2 GB CF card. With it I downloaded, compiled, and ran some of the simple programs on this educational project page:

The Headacher
08-26-2011, 07:08 AM
I've also had some trouble installing Linux on the microSD card of my Roboard 110. In the end, I managed to install one. I'm not sure the problem was due to the filesystem used, but I couldn't install the first couple of times when I tried to install to a ReiserFS formatted card. Now, I've installed with a EXT3 filesystem, and it seems to work just fine. For now, I have an 8 GB class 4 microSD card, since faster cards were not available in the computer/electronics shops here.

I haven't done a lot with the computer yet, as I've only got it recently. I've got quite some experience with Linux but installing was a challenge for me as well. Next step: creating a sleeker kernel.