View Full Version : Xbee - no ports listed on PC Settings tab

12-11-2010, 02:51 PM
Not sure why this isn't working, but no ports are listed on the PC Settings tab of the X-CTU software (nothing showed up in Device Manager). Here's the setup:

PC - Windows Vista, X-CTU version, USB connected to red Xbee breakout board with blue transmitter plugged in, red light on breakout board is on.

Bot - Serializer controller card with blue transmitter plugged in, power on.

The X-CTU software runs fine, the light on the red Xbee board is on. I noticed one strange thing in that no PnP initiated when I plugged it into the USB port. Usually, something should have started running in Vista to locate drivers. The red light came on the breakout board, but no ports get listed. Do I have to do something to force Vista to recognize the Xbee is plugged in?

12-11-2010, 03:49 PM
Try unplugging and re connecting the USB cable, you should get a "found new hardware" message, You may have to reinstall the drivers for a USB serial connection to the uart on the Xbee. I had to do that after reinstalling XP. But windows guided me through the process.

I don't know anything about Vista though..


12-11-2010, 08:10 PM
I tried re-installing the UART drivers -- no luck. The weird thing is, when I attach my USB to the Serializer directly (using the USB connector), Vista immediately registers recognition and the new COM port shows right up in Device Manager a second later. But, when I connect the USB to the red Xbee USB port, the red power light comes on but my PC doesn't even recognize that something has been plugged in (nothing in Device Manager, no "Found New Hardware", nothing). I think my Xbee unit may be defective in that the Power light comes on...but, that's all.

12-11-2010, 09:08 PM
I guess I'm out of ideas.. I tried removing the Xbee from my Xbee Explorer, and it still saw the ports. I disconnected the cable and it lost the port, but I had to restart XCTU after reconnecting the Explorer. Then the port came back.

Mine is an Xbee Explorer from Sparkfun.

I would suspect the board.


12-12-2010, 01:53 AM
First reboot with the thing disconnected. Connect the Explorer after XP boots all the way up and see if it works. If it does not then open the hardware Manager and see if you have anything listed under the Ports section. My first guess would be a driver problem.

12-12-2010, 08:37 AM
After several driver re-installs and reboots, I'm thinking that it's time to replace the USB Explorer board. I thought it was a Vista/XCTU problem, but I've seen others online who've said that they're able to run XCTU on Vista with no problem. And, even without using XCTU, Vista should have recognized something plugged in and a port should have shown up. This leads me to think that the little board is bad. I'll post the results of a replace in a while.

12-20-2010, 06:49 PM
Just a follow-up: I replaced the USB Xbee, Vista recognized it immediately, started it right up and I was up and running in 2 minutes. The old board must've been bad. Thanks for you help on this.