View Full Version : Maxstream XBee connection problems

05-11-2011, 05:41 PM

I am having issues connecting to my XBee module using the XBee USB explorer I try test/query and it says "Unable to communicate with modem".

I followed the steps in the tutorial: http://forums.trossenrobotics.com/tutorials/how-to-diy-128/xbee-basics-3259/ and installed drivers and XCTU using their .exe installers.

I plug in the explorer and the red and green on the board lights blink for a little bit then the red LED beside the USB connector stays lit up. Now when I run XCTU i can see USB Serial Port (COM3). The settings of XCTU are the same as in the tutorial but when I try to test/query it is "Unable to communicate with modem".

Any help greatly appreciated.

05-11-2011, 05:44 PM
What baud rate do you have selected? I believe new xbee modules are defaulted to 9600bps.

05-11-2011, 05:51 PM
The XBee module I have is the one from maxstream and its about a year old. The baud rate is 9600, I also checked the baud rate of the same port in window's device settings and its 9600.

Additionally my XBee modules once belonged to someone else who may have already configured them. I don't know what their configuration is or if it even matters at all.

05-11-2011, 05:59 PM
So have you tried all the possible baud rates? Do you have the correct USB FTDI drivers properly installed on your system?

05-11-2011, 06:05 PM
Sweet thank you so much.

I just tried all the baud rates and found one that it worked on. I guess the previous owner configured them differently.

Thanks again

05-11-2011, 06:07 PM
No problem. Have fun!