View Full Version : [Question(s)] Turtlebot arm servos not being recognized

11-18-2011, 03:28 PM
I am using a turtlebot arm and just finished getting the ROS sketch uploaded to the ArbotiX board when I ran into an error. I run the command to search for the servos after having plugged only one into the board and get the following result:

[email protected]:~$ rosrun arbotix_python terminal.py /dev/ttyUSB0
ArbotiX Terminal --- Version 0.1
Copyright 2011 Vanadium Labs LLC
>> ls
.... .... .... .... .... .... .... .... ....
.... .... .... .... .... .... .... .... ....
I have tried multiple cables and multiple servos to see if either was the problem. Neither of them turned out to be the problem. I have established that the servos do at least move, since I was able to issue them commands using PyPose. The only concern that I have is the the red light on the servos first light up when I plug them in, but do not stay lit for more than a second. I am currently running the arbotix board directly off of a iRobot Create battery (as opposed to going through the power board, since the only port on my power board is being occupied by the create). I don't think that should cause a problem, but figured I would mention it. Does anyone have an idea why my computer cannot read the servos, or any recommendations for other troubleshooting steps to take? Thank you very much!

11-18-2011, 11:27 PM
I've replied on answers.ros.org. Please don't cross post, the ROS experts here will also be on answers.ros.org.


11-19-2011, 12:27 AM
I apologize, I did not realize that the communities were so closely linked. It shall not happen again.