View Full Version : [Question(s)] phantom x 12 turret no response

01-18-2012, 10:17 PM
I have a new ax-12 turret. assembled, followed instructions to a T, double checked wiring. light blinks, but no servo movement.
I have tried c#, VB, and roborealm, (purchased the license). no luck. I've read everything I have found, still no dice.
Windows Vista operating system. If anyone has an Idea, or experienced a similar issue. Any advice would be appreciated.

Thanks All!

01-19-2012, 08:47 AM
What are you using to control your servos ? I recommend to start with RoboPlus (USB2Dynamixel Wizard) as they are the simple way to access your servos and to verify if they work. Please also note that if you want to move the servos form your ArbotiX, you have to plug an external power (an FTDI cable will not power motors and servos).

01-19-2012, 03:27 PM
I am using the included power source.
I can see the servos flash red when I open the com port.
I will try the suggestion tonight

01-21-2012, 06:09 PM
ahh, I see. You must purchase the dynamixel. I could try that, but I was hoping for a simple fix to a silly mistake I made.
Any suggestions?

01-22-2012, 08:56 PM
How are you trying to communicate with the servos if not with a USB2Dynamixel? An arbotiX?

01-22-2012, 09:52 PM
Yes, I am using the arbotix with the preloaded software.
I've read everything I can find on the subject, just not able to
Get any movement. It's very frustrating. I have no experience
In troubleshooting servos tied into an arbotix, running off of roborealm on
A pc. I've ordered the dynamixel, so if the servos turn out to be good then
I'm in the same spot as I am now(-$50 plus shipping).

Any ideas are welcomed

01-23-2012, 02:18 AM
Yes, I am using the arbotix with the preloaded software.

Have you tried loading the CommEXT code onto the ArbotiX? I'm not sure what firmware is shipping with the kits these days (ArbotiX boards ship with the PyPose firmware installed from Vanadium Labs, at one point I believe TR was loading the CommEXT firmware onto boards going into kits, not sure at this point). The CommEXT protocol is entirely different from what the PyPose firmware speaks, and I believe it is the CommEXT protocol that the roborealm module uses.