PDA

View Full Version : First time getting PhantomX Turret + ArbotiX Going



lvicks
03-12-2012, 02:37 AM
Hello,

I'm new to both the ArbotiX and Dynamixel components. I'm well versed in Atmel chips and general programming.

I constructed my PhantomX board and I'm looking to just test everything then write a simple python server that can control the turret for me. I'm using the CommEXT.py script to test basic functionality / movement. I am currently unable to get the actuators to move.

Here is what I get:


./CommEXT.py /dev/tty.usbserial-A400C242 -1
-1
-1
-1
-1
-1
-1
-1
Digital: -1


Here is what I've troubleshooted

Power is on and LED is lit
FTDI wire is correct orientation (tried both orientations, command fails on both, status light only flickers with correct orientation)
Power jumper set for VIN
J1 Jumper set to tie RX/TX, although I also tried toggling it.
Tried changing order of cables into Dynamixel
I can not confirm that the Comm_EXT firmware is loaded onto my ArbotiX board but this is what the turret manual says. I see the same output from CommEXT.py when the FTDI cable is connected to the ArtbotiX and when it is disconnected.

Does anyone have any ideas? I can burn the Comm_EXT if necessary, I assume this is CommExt.pde.
thanks!

lvicks
03-13-2012, 03:11 PM
Commander Firmware was not loaded despite manual claims, had to compile and load. Works now.

lnxfergy
03-13-2012, 03:39 PM
Trossen stopped uploading firmware some time ago I believe. The product page has been updated, but the manual is still out of date. I'm sure they'll get it updated soon.

-Fergs

gecf343b1
05-08-2012, 10:27 PM
Hello,

I'm a complete green horn when it comes to programing, but I like to learn new things and try and figure things out. I got a dumb question I'm hoping someone could help point me in the right direction.

I have a Phantom X Robot Turret, and I was wonder if I should load the Comm_EXT Proportional sketch onto the Arobotix board before trying to setup control using Roborealm?

Listed below is my hardware/software setup:

Windows 7 64 bit
Arduino 0018
Python 2.7.3
wxPython2.8-win32
pyserial-2.5.win32
PhantomX-Robot Turret with 2 each AX-12A servos
ArbotiX robocontroller - FTDI usb cable
Roborealm

Thanks for the help.

lvicks
05-15-2012, 04:43 PM
you upload the CommExt applet

gecf343b1
09-02-2012, 05:20 AM
Is there GUI software available that emulates the Arbotix Commander?