PDA

View Full Version : [Noob] Problems in Ros Installation



natanoj
07-22-2012, 06:15 AM
Hi all!
Im new in this. In a few months I will start a project in the university, where I will work with NaoRobot and ROS.


I have start to install ROS in my linuxOS, and I'm reading the tutorials:
http://www.ros.org/wiki/fuerte/Installation/Overlays

W (http://www.ros.org/wiki/fuerte/Installation/Overlays)hen I write: "rosws update turtlebot"

appears the following error:
[turtlebot] Installing https://kforge.ros.org/turtlebot/turtlebot (None) to /home/jony/fuerte_workspace/turtlebot
WARNING Command failed: 'hg --version'
errcode: 127:
/bin/sh: 1: hg: not found

Exception caught during install: Error processing 'turtlebot' : Unable to create vcs client of type hg for /home/jony/fuerte_workspace/turtlebot: "Could not determine whether hg is installed 'hg --version returned 127, maybe hg is not installed'"


ERROR: Error processing 'turtlebot' : Unable to create vcs client of type hg for /home/jony/fuerte_workspace/turtlebot: "Could not determine whether hg is installed 'hg --version returned 127, maybe hg is not installed'"


Apparently I followed all steps, but I don't know why appear this error.

Thanks for all, and sorry for my bad english.
Bye!

tician
07-22-2012, 08:58 AM
It would appear you do not have mercurial installed.

sudo apt-get install mercurial should hopefully install all you need.

natanoj
07-22-2012, 09:19 AM
It would appear you do not have mercurial installed.

sudo apt-get install mercurial should hopefully install all you need.

Perfect, this was the problem. Thank you!
Bye!