PDA

View Full Version : [Question(s)] Getting RX-24F to work using RX Bridge on ArbotiX board



goldscott
10-04-2012, 10:39 AM
Hi All,

I'm new here. I just got the WidowX turret with RX-24F servos, and I cannot seem to get the servos to move or respond. Right now I only have one plugged in for testing.

I've ran both the PyPose and CommExt sketches, but nothing happens.

The board (12V) and bridge (16V) have the correct power supplies hooked up, and I've scoped the serial TX pin 17 of the uC, I'm sending commands properly at both 1Mbps and 57.6kbps (not sure what baud rate to use). I haven't scoped the actual data lines to the servo after the bridge (RS-485 converter).

On power up, the servo LED turns red for a moment.

I've looped through sending commands to every ID (0 to 254) and I get no response from the servo.

Any ideas?

Thanks,
Scott

DresnerRobotics
10-04-2012, 11:17 AM
Which Arbotix library revision are you using?

What build of the Arduino IDE?

goldscott
10-04-2012, 11:31 AM
I tried using both 0014 and 0015 ArbotiX libraries.

Arduino 1.0.1.

DresnerRobotics
10-04-2012, 12:57 PM
If you're using 1.0.1 you need to be using 0015.

Arbotix library 0014 is for 23 beta build of the IDE.

Do you have the correct board selected?

goldscott
10-04-2012, 01:10 PM
I'm currently using Arduino 1.0.1 and Arbotix 0015. I have the correct board selected.

DresnerRobotics
10-04-2012, 01:23 PM
Let's try a bit more basic approach. Upload this and see if you get any response out of Servo ID 1:

#include <ax12.h>
#include <BioloidController.h>


BioloidController bioloid = BioloidController(1000000);
//try once at 1mbps, once at 57600 just to confirm your servos are set right


void setup(){
}

void loop(){
SetPosition(1, 0);
delay(2000);
SetPosition(2, 1023);
delay(2000);
}

I'm in the process of verifying/updating all of our code examples for the new 0015 library and 1.0.1, but have not gotten to the Comm_EXT sketch yet. It's possible there could be a problem there.

goldscott
10-04-2012, 01:41 PM
I just tried that sketch with both baud rates, and the servos do nothing still.