PDA

View Full Version : Dynamixel Wizzard errors



george.profenza
10-06-2012, 10:49 AM
Hello,

I'm currently having some nasty issues with the Dynamixel Wizzard.
The robot I'm working on uses 8 motors and everything worked fine until now.
When I run the wizzard and scan for motors I get a .net error:


See the end of this message for details on invoking just-in-time (JIT) debugging instead of this dialog box.


************** Exception Text **************
System.NullReferenceException: Object reference not set to an instance of an object.
at ROBOTIS.ControlLibrary.DXLTreeView.AddItem(Int32 baud, TreeNode item)
at ROBOTIS.DynamixelWizard.MainForm.DXLTreeView_Updat eTreeView(Int32 baud, TreeNode item, UpdateState state)
at ROBOTIS.ControlLibrary.DXLTreeView.OnUpdateTreeVie w(Int32 baud, TreeNode item, UpdateState state)
at ROBOTIS.ControlLibrary.SearchPage.AddDXLTreeViewIt em(Int32 baud, Int32 id)




************** Loaded Assemblies **************
mscorlib
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.5456 (Win7SP1GDR.050727-5400)
CodeBase: file:///C:/Windows/Microsoft.NET/Framework/v2.0.50727/mscorlib.dll
----------------------------------------
DynamixelWizard
Assembly Version: 1.0.12.0
Win32 Version: 1.0.12.0
CodeBase: file:///C:/Program%20Files%20(x86)/ROBOTIS/RoboPlus/Wizard/DynamixelWizard.exe
----------------------------------------
System.Windows.Forms
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.5460 (Win7SP1GDR.050727-5400)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.5456 (Win7SP1GDR.050727-5400)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Drawing
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.5462 (Win7SP1GDR.050727-5400)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
ControlModel
Assembly Version: 1.0.4500.32514
Win32 Version: 1.0.0.0
CodeBase: file:///C:/Program%20Files%20(x86)/ROBOTIS/RoboPlus/Wizard/ControlModel.DLL
----------------------------------------
ControlLibrary
Assembly Version: 1.0.4500.32515
Win32 Version: 1.0.0.0
CodeBase: file:///C:/Program%20Files%20(x86)/ROBOTIS/RoboPlus/Wizard/ControlLibrary.DLL
----------------------------------------
System.Data
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.5420 (Win7SP1.050727-5400)
CodeBase: file:///C:/Windows/assembly/GAC_32/System.Data/2.0.0.0__b77a5c561934e089/System.Data.dll
----------------------------------------
System.Xml
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.5420 (Win7SP1.050727-5400)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Xml/2.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
System.Transactions
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900)
CodeBase: file:///C:/Windows/assembly/GAC_32/System.Transactions/2.0.0.0__b77a5c561934e089/System.Transactions.dll
----------------------------------------
System.EnterpriseServices
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.5420 (Win7SP1.050727-5400)
CodeBase: file:///C:/Windows/assembly/GAC_32/System.EnterpriseServices/2.0.0.0__b03f5f7f11d50a3a/System.EnterpriseServices.dll
----------------------------------------
System.Configuration
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.5420 (Win7SP1.050727-5400)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Configuration/2.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll
----------------------------------------
FirmwareManager
Assembly Version: 1.0.4500.32516
Win32 Version: 1.0.0.0
CodeBase: file:///C:/Program%20Files%20(x86)/ROBOTIS/RoboPlus/Wizard/FirmwareManager.DLL
----------------------------------------


************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.


For example:


<configuration>
<system.windows.forms jitDebugging="true" />
</configuration>


When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.

I click Continue on the error screen (the other option is Quit)
but I can only see 2 or 3 of the motors. Each time I do this I see different motors.

The upgrade notification pops up, but the application crashes when I try to do the firmware upgrade :(
In my code, I get instruction errors and the motors do not respond correctly.

This looks like a software/firmware issue related to upgrades.
I've turned power on/off and the LEDs on the motors light up properly, so the hardware should be fine.

Right now I'm downloading a new version of the RoboPlus software to intall.
Any ideas/hints I could try ?

Thanks,
George

Also, I'm new to the forum, so please let me know I posted in the wrong place or anything.