PDA

View Full Version : Trouble Running Pypose (Mac)



Brummel
02-13-2013, 04:22 PM
I recently purchased a Phantom X arm for a school project. After following the set-up instructions for the robotix robocontroller, I was able to successfully run pypose and pose the robot on a school windows 7 computer. However, on my personal computer (Macbook Pro OS 10.6.8), I followed the steps again, downloading Python 2.7, wxPython and Pyserial. After opening pypose in Idle and running, I encounter the following error:

Traceback (most recent call last):
File "/Users/benbrummel/Desktop/ARM 2013/arbotix-0015/pypose/PyPose.py", line 411, in <module>
frame = editor()
File "/Users/benbrummel/Desktop/ARM 2013/arbotix-0015/pypose/PyPose.py", line 96, in __init__
name = getattr(module, "NAME")
AttributeError: 'module' object has no attribute 'NAME'

I have very little experience in python, and when I searched "AttributeError: 'module' object has no attribute" on google, I was unable to get any of the suggested solutions to work, as most seemed case specific.

If anyone knows how to deal with this error, that would be great, as using pypose on my personal computer would allow me to work on the project on my own without needing access to a school computer.

tician
02-13-2013, 05:27 PM
Have you tried using a terminal instead of IDLE? "cd" to the "arbotix-0015/pypose" folder then run "python ./PyPose.py".

Brummel
02-13-2013, 06:37 PM
I tried running it from terminal, the python launcher, and the build applet function. The terminal gave me the same error and both the launcher and the applet just opened and closed.

jwatte
02-13-2013, 07:46 PM
It may be that the default Python on your Mac is Python 3 instead of Python 2.
Try running it explicitly using "python2" from the Terminal command line.

Brummel
02-13-2013, 10:16 PM
I tried running it explicitly using python2 in the terminal as you suggested and got the same error again:

ben-brummels-macbook-pro:pypose benbrummel$ python2 ./PyPose.py
PyPose starting...
Traceback (most recent call last):
File "./PyPose.py", line 411, in <module>
frame = editor()
File "./PyPose.py", line 96, in __init__
name = getattr(module, "NAME")
AttributeError: 'module' object has no attribute 'NAME'

I appreciate the help though. Hopefully I will figure out a solution, or maybe someone else who has had the same problem can help me.

kamondelious
02-14-2013, 12:51 AM
Is there a /Users/benbrummel/Desktop/ARM 2013/arbotix-0015/pypose/tools/ directory? If so, what is in it?

I have these :

$ ls -1 tools/
models
NukeEditor.py
NukeEditor.pyc
PoseEditor.py
PoseEditor.pyc
SeqEditor.py
SeqEditor.pyc
Terminal.py
Terminal.pyc
ToolPane.py
ToolPane.pyc

At the ends of each of the .py files (except for ToolPane.py) there should be declarations for NAME and STATUS. If those files are missing or empty, I could see you getting that error.

Cheers!

;)

lnxfergy
02-14-2013, 02:04 AM
I think this is the same issue as https://code.google.com/p/arbotix/issues/detail?id=35&can=1

Luckily, it was recently fixed, but after the 0015 release. Can you try downloading this bleeding edge version: https://github.com/vanadiumlabs/pypose/zipball/master

-Fergs

Brummel
02-15-2013, 08:26 AM
Thanks Fergs,

The new release got it running. I appreciate all the help.