View Full Version : Dynamixel AX-12a lights up and searches, but can't be found

03-01-2013, 03:21 AM
I'm setting up my Dynamixel AX-12A's, but can't search for it successfully.

When I plug in power, the led turns on for 2-3 seconds and then goes away. Using a charged 3S Lipo.

My usb2dynamixel plug is turned on, visible on the computer over the COM3 serial port, driver seemingly installed correctly, connected to my AX-12a. When I perform a search for the AX-12 using Dynamixel Wizard, it never finds anything - tried basic and exhaustive searches. The status led is always on on the usb2dynamixel plug. When it's performing a search, then also the traffic led is blinking. It's turned to TTL mode, but also tried the switch in other modes.

Are there any additional signals I should look for? Should the servo only show the status for a couple of seconds after plugging in the power or permanently? Other tips?

03-01-2013, 04:26 AM
The light should come on only briefly. It's only constant when something is wrong. When you said it's turned to TTL I assume you mean the usb2dynamixel?

03-01-2013, 04:53 AM
Ok, good to know that it's not because of any errors.

Yes, exactly - usb2dynamixel is in ttl mode, though I also tried the other modes.

Ideas on what I could try next? I've pretty much gone through the standard debugging list.

03-01-2013, 05:17 AM
How many AX-12 at one time? If they are brand new, they will very likely all have the same ID of 1. Because of that ID conflict, it is unlikely that any will show up until you connect them one at a time to rename them.

03-01-2013, 06:59 AM
Hooked up just one to avoid conflicts until I have a proof of concept working.

Could there be any default serial speed mismatches? Fresh unit from factory and new install, so don't see how that can be.

03-01-2013, 07:45 AM
I have never encountered an AX-12/18 from a factory box that was not set to 1Mbps and ID==1 (excluding predefined and labeled servos in Comprehensive and Premium kits - same baud rate, but already re-named). The RX/EX/MX-series usually have their default baud rate set to 57600 bps and ID==1.

Have you tried using the firmware update function? Basically, if the servo is functional, then the firmware updater will find it (accesses the bootloader before the normal firmware can take over). Open the Dynamixel Wizard and click on the Update Firmware button (do not click the connect button to search for servos - the updater will do that on its own). Follow the on-screen directions and connect only one AX-12 at a time to the USB2Dynamixel (set to TTL) with an external power source (such as a 12V SMPS with SMPS2Dynamixel).

What OS are you using? Windows 7 on some of our machines would require the default driver to be uninstalled (FT232RL in the USB2Dynamixel would be identified as a bluetooth dongle) and the LN-101 driver to be manually installed twice to actually produce a working COM port. Not really sure why, but the first driver installation causes it to show up as some sort of intel COM port that never works - it would "attempt" to connect, but never work. After the second driver installation, we wind up with a second COM port that actually works as it should.

03-01-2013, 11:59 AM
Also if you have it connected to a cheap USB hub or something similar I've seen communication errors... For example... attached to a keyboard usb hub or monitor usb hub. If it is not already, try connecting it to the back of the comupter.

03-01-2013, 04:07 PM
I'm using Windows 7. After installing drivers, the device popped from USB devices to ports and started showing as COM3. I'll try the double installation trick and then the other ideas.

03-01-2013, 04:46 PM
Have you tried a firmware recovery yet? Connect only one servo, and make sure it has power. Disconnect from the USB2Dynamixel in the Dynamixel Wizard. Then press the Firmware Recovery button and follow the wizard to connect to the U2D again, and power off/on the servo to get it into recovery mode. If this works, the servo should be back in default settings, and be found with a basic scan.

03-19-2015, 10:57 PM
I am having same problem:( USB2Dynamixel at COM3 is found and connected to the laptop successfully, ensuring in TTL mode and only one motor connected with ID 1. However, It fails to find the motor, neither successes in the firmware recovery mode.

I compared the signal of the data pin of two USB2Dynamixels (one is the above mentioned, another is in good condition) when searching dynamixels at baud rate 1000000 and 57600, as below. I didn't change any other device or setting except the USB2Dynamixel.
5851 Abnormal

As you can see, there is a voltage drop to 3.72V when the USB2Dynamixel is idle. Any idea why this happened? Is that mean there is hardware problem with this USB2Dynamixel? It works before, and problem comes with instruction checksum error when sending command to the motor. Suddenly failed to find motors.

03-20-2015, 05:09 AM
3.72V is not great but it should be considered high by both sides (the servo uses a 74HC126D (http://www.nxp.com/documents/data_sheet/74HC_HCT126.pdf)chip which is rated for detecting a high level above about 3.5V when powered at 5V, and the FTDI FT232 chip is much lower than that).

Aside from that... :/
If that's a possibility, I would say: change the offending USB2Dynamixel if it's the only thing that does not work. It might be a bettter use of your time and effort.

03-20-2015, 10:18 AM
I agree with Xevel -- change the USB2Dynamixel out. It may have seen some damage -- too high voltage, short, connected to a damaged servo, or something like that. I have two USB2Dynamixels, one of which was similarly flaky, and I'm not using that anymore.

Another option is to get a OpenCM-9.04B. For $20 (or $10 if you want to do some soldering yourself) you can get something that can both serve as a TTL bus interface over USB (with a little bit of code) AND which can serve as a self-contained controller. It's a great deal IMO.

If you think it's too big/bulky/unprotected, there's also the USB2AX, which is a fine drop-in replacement for the USB2Dynamixel -- and much less bendy on the USB port, too.

03-21-2015, 07:26 AM
Okay. It seems that is the only right thing I should do. Anyway, Thank you very much for your help!