View Full Version : [Question(s)] Dynamixel AX-12A not responding

03-03-2013, 02:53 PM
Some of my AX-12 servo's changed there id. After reading related posts (seemed to be a known problem) i tried to reset the ID. I had just 1 servo connected to my ArbotiX Robocontroller i send a "set id" (ax12SetRegister AX_ID) command.
Now my servo is not responding at all. (Checked id 0-255 on a rang of baud rates)

Is there a way to reset the ax-12 (with a ArbotiX Robocontroller) I don't own a USB2Dynamixel.

Hope somebody can help me.


03-03-2013, 07:40 PM
If you're seriously playing with these kinds of servos, getting one is a pretty important investment. I know of no other way to reset/recover the firmware than using an USB2Dynamixel.
Maybe some of the Robotis controllers can emulate the USB2Dynamixel function? Anyone know?

03-03-2013, 08:05 PM
Maybe some of the Robotis controllers can emulate the USB2Dynamixel function? Anyone know?
You should be able to program a CM-510/530/700 using embedded-c to simply pass everything between the USB UART and the dxl UART, but it's not possible using RoboPlus Task. An arbotix would probably be able to do it as well. The USB2Dynamixel is pretty much just an FT232RL USBtoUART with a bit of full-duplex to half-duplex logic for the 'ttl' dynamixel bus.

03-03-2013, 08:40 PM
Have you tried https://github.com/KurtE/AX12_Test ? It has a few commands that are using the broadcast id. If they respond to that it might be something simple that doesn't require a full reset/restore.

03-04-2013, 12:58 PM
Thanks all. Guess my next order will be the USB2Dynamixel. :happy:

03-04-2013, 01:13 PM
Another option is the USB2AX. http://www.seeedstudio.com/depot/usb2ax-p-1349.html

You still have to provide power to the servos, but I use a custom perf-board + power supply setup for that.

03-04-2013, 01:41 PM
I just bought one of those! I'm using the usb2dynamixel right now with my raspberry pi. Looking forward to switching it out with one of those.