PDA

View Full Version : Playing with the PhantomX Reactor



Xevel
03-12-2013, 09:26 PM
Hey guys!

I received my prized prize last week, yeah :) Thanks guys!!!

I started building it tonight. I hope I can bring it to Innorobo (an international robotics summit in France) next week, next to Xachi on the Robotis booth :)

I posted a first feedback on my blog.
PhantomX Reactor Arm Part 1 (http://www.xevel.fr/blog/index.php?post/2013/03/12/PhantomX-Reactor-Arm)

So far, I have found some strangeties and details that I think could be improved. All my apologies if these problems have already be talked about/solved, I've been having a hard time following what's going on here in the last few month...
Strange stuff:
- there were a lot of extra hex keys in the package!

Proposed improvements, by order of importance:
- get AX hub assemblies that really do their job, because THIS (http://www.youtube.com/watch?v=pJ-loOqt1lU) is just not cool.
- use only quality hex keys (the 1.5x75mm red and grey hex driver is just useless as driver... only use I could find for it was to put the nuts in the dynamixels).
- clean up the laser-cut parts ;)
- localized power cords for the power supply maybe (not really important, but a nice touch)

Gertlex
03-13-2013, 10:32 AM
Regarding the AX-12 bracket (I didn't bother with sound, just watched), I've found that overtightening the 3mm bolt is usually bad, so I tighten how I like it, check, remove it, loctite, and put the bolt back in.

Edit: On reading the blog post, I see you mention the plastic bushing. My more recent AX-12s have had very snug-fitting ones, so you're not alone in that regard. The ones I've dyed for Numa weren't any worse, though, so I don't think dyeing the parts black is the cause. (Dyeing the Molex connectors seems to make for loose electrical connections...)

KevinO
03-13-2013, 11:52 AM
My hubs make that exact sound if I over tightened them as well. It puts a slight camber in the bracket so it starts squeaking. Usually a quarter turn back off fixes it. A bit of Loctite and it never loosens.

KevinO
03-13-2013, 12:03 PM
I just looked in my AX hub bin and checked a few. They all have that slight bow you were describing. The white ones and the dyed ones. So I think that is just how they are all now. It's nothing Trossen has done for sure.

DresnerRobotics
03-13-2013, 02:22 PM
Hey guys!

I received my prized prize last week, yeah :) Thanks guys!!!

I started building it tonight. I hope I can bring it to Innorobo (an international robotics summit in France) next week, next to Xachi on the Robotis booth :)

I posted a first feedback on my blog.
PhantomX Reactor Arm Part 1 (http://www.xevel.fr/blog/index.php?post/2013/03/12/PhantomX-Reactor-Arm)

So far, I have found some strangeties and details that I think could be improved. All my apologies if these problems have already be talked about/solved, I've been having a hard time following what's going on here in the last few month...
Strange stuff:
- there were a lot of extra hex keys in the package!

Proposed improvements, by order of importance:
- get AX hub assemblies that really do their job, because THIS (http://www.youtube.com/watch?v=pJ-loOqt1lU) is just not cool.
- use only quality hex keys (the 1.5x75mm red and grey hex driver is just useless as driver... only use I could find for it was to put the nuts in the dynamixels).
- clean up the laser-cut parts ;)
- localized power cords for the power supply maybe (not really important, but a nice touch)

The feedback is much appreciated.

Re: 1.5mm driver: We're actually not sending out those 1.5x75mm hex driver for that exact reason, I'm not even sure why you got one. We're currently sitting on about 500 of them after ordering them only to find out that the tolerances are crap and so our kits guy may have just thrown one in to get rid of some, haha. We instead went with Wiha drivers for the 1.5mm driver. Also, you may have extra parts/tools simply because yours was a prize edition one that we put together specifically for you, these aren't normally included with production kits.

The AX hub assemblies we have no control over unfortunately. Robotis makes them, and they can be over-tightened, causing that squeaking noise. I think the slight 'puffiness' is so they stay put in the brackets, both our dyed black and stock white ones are like that.

Laser cut parts are being switched over to Plexiglas-G very soon, so no more dirty ABS parts.

Can't really include power cords for every country, unfortunately. Logistics is a big deal when this many arms are being sold, so having to specially pack region-specific power cables would be a nightmare. The power supplies can operate off of 110/220v, so only a plug adapter is needed.

Can't wait to see more!

Xevel
03-13-2013, 09:35 PM
Thanks for all the answers :)


On the question of the hub assembly:
As far as I understand, this part and the M3 screw are made to be fixed relative to the servo, and to let the bracket turn around it.
Here, the noise comes from the body of the hub grinding on the interior of the hole in the bracket, it's not the flange and/or washer touching the sides of the bracket.

I understand that if I over-tighten the M3 (like I may have done in the video) the part has a risk of compressing the bracket, washer and servo together, resulting in the same noise, but this is not the effect I'm talking about here.

In the Bioloid Premium kit I got 2.5 years ago, all these white little hub parts did let the bracket turn freely. When you assembled them, you had to be extra careful because they would not stay in place in the bracket by themselves, they could run freely and get in as freely. Here, when you put the hub in the hole of the bracket, it is hard to put it through, it can stay there, and it doesn't rotate without applying a great torque.

I'll ask Robotis directly since they are the ones who are responsible for this :)

Xevel
03-16-2013, 07:24 PM
Assembling my Reactor arm: Part 2! (http://www.xevel.fr/blog/index.php?post/2013/03/16/PhantomX-Reactor-Arm-%28Part-2%29)

4580