View Full Version : IMAX B6 Charger "INPUT VOL ERROR"

05-31-2013, 04:31 PM
Hello all,

Recently my Imax B6 charger gives me a "INPUT VOL ERROR" whenever i plug it in. Here's the background:

The charger is about a month old and has been used 4-5 times to charge a 2200mAH lipo at 2.0A using normal charge mode and balance charge mode. I'm using the 12V 5A wall wart supply from Trossen.

A few weeks ago i accidentally drew the lipo down to 7.68V which is quite terrible. I thought it'd be toast, but i put it back on the charger, balanced mode, at 2.0A and it charged up to proper voltage fine. Since then it feels like the battery depletes faster than usual so i tried to "reboot" it by discharging it.

I set the charger to discharge mode and and set it to discharge to 9.0V at 1A. About 5min into this process, the alarm started going off and the "INPUT VOL ERROR" first appeared.

Since then, whenever i plug the charger in (even with no batter or balance sense connected at all) it immediately starts alarming and showing the "INPUT VOL ERROR". I can't even use the menus, it goes straight to alarm. I tried different power outlets around the house, all the same.

Today i tried connecting the charger to my car battery. This time it started up fine, no alarm. I set the charge rate to 1.0A and went back inside the house.

The charger will now power on with the wall supply, but even charging at 1.0A, it will only charge for 3-5min, before the alarm goes off with the "INPUT VOL ERROR".

According to the internet (this error is common), this error message means the supply doesn't have enough juice for your charge rate.

However, according to the actual owner's manual, the error means: "Erroneous selection of voltage of Lithium pack, please check the voltage of the battery pack."

I guess its pointing to the wall supply as the culprit or the battery itself. I suppose its more likely i damaged the battery, but if so, why does the charger fault even with no battery connected? Maybe i damaged the wall supply? I should probably go and try to charge the battery with the car battery and see how far it gets along.

Any ideas? Thanks!

Update: I just tried plugging the charger into the wall supply, but no battery. Just sitting there doing nothing (but charger powered on), it sits for 3-5min before the alarm goes off.

05-31-2013, 05:44 PM
Sounds like a problem with the charger to me. Some sensor might have overheated while you were discharging, perhaps?

i tried to "reboot" it by discharging it.

I *think* this only works with NiCd batteries, and is actually a bad idea with LiPos. Once you "hurt" a LiPo I think you can't actually reverse the damage, and have to live with the lower capacity.

05-31-2013, 06:55 PM
Lithium batteries have no memory, just a finite number of charge/discharge cycles at a rated capacity. If you discharge a LiPo below ~3.2V per cell, then you are killing it pretty quickly (reducing the number of charge/discharge cycles that it will ever be able to provide at a rated capacity) and potentially killing it dead ("fire in the hole!").

Have you checked the voltage the SMPS is producing? Did you get any errors when charging solely from the car battery? It sounds like the charger was damaged during discharge and/or the SMPS is defective. Looking at the second to last page of the IMAX B6 manual from skyrc's site (page 33, "Maximum Circuit Power Chart") shows it should not be able to discharge a 3S lipo at more than 0.4A (self-limited by the charger).

Low-level discharging only 'resets' certain cadmium based batteries that have a very powerful memory effect. Basically a very, very regular charge/discharge cycle (like on solar powered satellites) would cause the effective capacity of the battery to decrease, and after some number of regular cycles it will not charge beyond some capacity no matter how long it is charged. Discharging it below normal would cause it to again permit a fuller capacity charge.

Side note: One of the tiny LiFePO4 batteries I ordered along with the 4S 20Ah battery came with a voltage of 0.8V, but appears to be holding a charge now at ~3.3V. If it were LiPo or Li-Ion, I expect it would be dead = dead. The A123 26650 2.3Ah cell I bought several years ago, rarely used, and never charged is still sitting at 3.29V.

06-03-2013, 05:44 PM
Today i wired the 12V 5A supply directly to the bot. It was unable to run more than 2 legs without "browning out". With six legs all connected it couldn't even stay powered on. The green light on the power supply with blink out and reset over and over. With four legs it'd stay on, but reset if i moved the legs too much. Only with only 2 legs could it stay powered on through testing.

I also tried three different sets of two legs to make sure the problem wasn't a fault in one of the legs. All three sets of two legs behaved the same.

Between this and the charger error, i think this power supply is shot.

This also makes me want a benchtop supply so i can monitor the current draw as a diagnostic too.

06-03-2013, 06:22 PM
5 Amps is hardly enough to power a hex. Correct me if I'm wrong but one servo can pull a little over 2 amps under load.

06-03-2013, 06:31 PM
Yeh you're right what the heck am I thinking. 2-3 legs sounds about right then. gah

I'm thinking about getting one of these for the job: http://www.circuitspecialists.com/12-volt-18-amp-power-supply.html

(http://www.circuitspecialists.com/ps1-150w-12-12-volt-power-supply.html)Think that'll do 'er?

06-03-2013, 07:24 PM
Considering that a well functioning 12V 5A SMPS can power a DARwIn-OP while walking/kicking/falling/recovering even after the losses of a 6' (22AWG) barrel connector extension cable (as well as Bioloid Humanoids and the Bioloid Hexapod while walking), it should easily be able to power 18 AX-12/18 under light load (at a bare minimum, it should be able to keep them all powered on with torque off).

06-03-2013, 07:46 PM
True Tician. I assumed Dan was trying to run/walk the robot with just that power supply.

06-03-2013, 08:40 PM
I had it upside down on its back with the legs flailing around in open air. Hrmmm

06-04-2013, 08:07 AM
I ordered a cheap 12V 25A fixed switching supply for $50. That's 1.4A per servo so hopefully that'll cut it if i'm not stalling servos. From what i gather the AX-12 stall current is 900-1500mA. I run it legs up in the air most of the time so it'll definitly work in that config as a minimum. I run the bot on the bench 90% of the time, so this will be pretty handy i think.

I'll also use it to power the battery charger and see if it cures its issue.

06-04-2013, 11:15 AM
Yeah, 5A won't do it when putting load on the movement. On the bench, I typically use a 5A bench supply for idle current, and parallel it with a LiPo battery that provides the current needed when actually moving (especially when starting moving.) I set the bench supply voltage so it "floats" the LiPo at a safe voltage, rather than having it at "full charge" voltage. Something like 15.6V for a 4S LiPo. This avoids burning out the LiPo through over-charging.

I can parallel my bench supply to give 1x10A instead of 2x5A, but even 10A is not enough for the current spike when all the joints start moving at the same time...