PDA

View Full Version : [Question(s)] Urgent Help WIth pypose and arbotix.(P.S. im a total beginner)



1313opkko
09-02-2013, 12:48 AM
I installed pypose software according to https://code.google.com/p/arbotix/wiki/GettingSetup
A (https://code.google.com/p/arbotix/wiki/GettingSetup)fter connecting the board to the pc and choosing the port(com port 7) and conecting the motor to the board with power supply of 13v (motor im using dx-117).

i tried to test the bot so i only connected a motor. By the way the arbotix comes with the rx shield.

I went to the servo terminal and clicked "ls" but it failed to read the motor
Fail Read
Fail Read
Read Failed: Servo ID = 1
Fail Read
Read Failed: Servo ID = 2
Fail Read
Read Failed: Servo ID = 3
Fail Read
Read Failed: Servo ID = 4
Fail Read
Read Failed: Servo ID = 5

any idea whats wrong? Just to let u know though when the power supply supplies power, the motor will blink a red light once.

Oh and im using the fdti cable

DresnerRobotics
09-02-2013, 01:18 AM
Have you set the baud rate on the DX-117?

1313opkko
09-02-2013, 10:46 PM
Do i set the baud rate using arduino? cos i still have misconceptions on how the board and motors work together

darkback2
09-03-2013, 08:16 AM
Ok...so two things. I am not sure if this will help you.

When two devices try to talk to eachother over a serial connection they have to be set to the same baud rate. If not then they can't talk to eachother. The easiest way to change the settings on a dynamixel servo is to use roboplus, the software from Robotis, and a usb2dynamixel connector.

Start off by checking everything and making sure you set things up as per the directions. There are a lot of little steps and it is easy to miss something especially when you are just starting out. After that if you need to you can order a usb2dynamixel.

Something to try before you buy a usb2dynamixel and download roboplus... go to here (http://learn.trossenrobotics.com/arbotix/1-using-the-tr-dynamixel-servo-tool#&panel1-1): Learn.trossenrobotics.com and follow the instructions to install the DynaManager software. Follow the instructions carefully. I am not sure if it will work with the RX bridge in place, or with servos that have not already been set to the right baud rate. One last thing. If you do use a USB2dynamixel you will need some way to power the servos without connecting the arbotix. I was at trossen last week and they had a powered 6 port hub for dynamixel servos. I can't seam to find it on their website...Probably because of the time in the morning it is. You can also make your own power cable by cutting the signal cables on a regular dynamixel wire.

I really hope this helps more than it hurts, and I hope the learn.trossenrobotics.com link helps you out. Keep us posted and let us know what you end up with.

DB

1313opkko
09-16-2013, 11:36 PM
Hey i solved it so i had to use roboplus to change the IDs of the motors and baud rate manually before any of the programs can locate the motors. Yea i tried DynaManager but it doesnt work because it cant locate the motors either . I had to use roboplus( Dynamixel Wizard to Change the Motor IDs manually and baud rate too. And Also i lacked a power supply to the arbotix board .

Initially i thought that a power supply for the rx bridge + ftdi cable 5v power to the board would be enough for the motors to run. But i had to power up the bot with one more power supply(number 16 according to the pdf file for the arbotix robocontroller). I think thats that and thanks for the help darkback!