PDA

View Full Version : arduino isp not working



deathwiz
12-14-2013, 10:41 AM
I have an arduino mega 2560 that i am using as an isp to load onto an arbotix chip. I have been following this link (http://letsmakerobots.com/node/35649) to set up the isp. i first uploaded the idp script to the mega. Then i connected the isp cables to the correct pins and then other end to the isp port on the arbotix chip. Then i tried to upload the pypose sketch to the arbotix chip by clicking "upload using programmer" and i get this error message.
avrdude: stk500_program_enable(): protocol error, expect=0x14, resp=0x50avrdude: initialization failed, rc=-1
Double check connections and try again, or use -F to override
this check.


avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

What am i doing wrong?

jwatte
12-14-2013, 02:52 PM
In the Arduino IDE, you should choose Tools -> Programmer -> Arduino as ISP

deathwiz
12-14-2013, 04:32 PM
I I did that as well. I just forgot to say that. The board was set to arbotix and port was selected. Ant other ideas

jwatte
12-14-2013, 09:25 PM
avrdude: stk500_program_enable(): protocol error, expect=0x14, resp=0x50

That seems to me like it's trying to use the STK500 path, not the Arduino-as-ISP path. However, it could be that Arduino-as-ISP uses the STK500 code and just didn't rename the error message/function.

I have only used Arduino as ISP once, and then, following the instructions, it worked for me, so I don't know what else could be wrong. My guess would be some mis-match between the actual sketch you're running.