PDA

View Full Version : [Question(s)] Accuracy issue with Grove 3-axis compass (SEN12753P)



jerry7580
06-20-2014, 11:28 AM
I purchased and connected the Grove 3-axis compass to my Arduino Uno, ran the example code and it appeared to work. However, as I progressed with this, it became very apparent that I am not getting anywhere close to the accuracy of 1 to 2 degrees that is stated in the literature. I can rotate it to North (0 degrees), then rotate 90 degrees with the expectation of a 90 or 270 degree reading. The resulting reading may be off by 20 to 30 degrees. Can anyone provide suggestions as to how I should proceed on this? Would especially love to hear from anyone that has used this compass successfully as well as anyone that has experienced similar issues. Thanks!

Xevel
06-20-2014, 01:02 PM
Is there any huge metallic thing around? it could be the frame of your desk, a big cabinet... or any big magnet, that would be a problem too. Anything with magnetic properties will modify the local magnetic field and will cause huge errors.


Ideally, you would need to calibrate ("soft iron calibration" and "hard iron calibration") the sensor to "erase" fixed metallic masses around you.

jerry7580
06-22-2014, 12:13 PM
My desk is wood and there are no large metallic objects close to the compass. Also, the compass app on my cell phone (Samsung Galaxy S4) appears to work properly in exactly the same location. In pursuing the documentation in detail, I did find that there are sensitivity settings associated with the Honeywell HMC5883L chip that is used by this product. Has anyone found the need to test other sensitivity settings or something of that sort. Have you personally successfully used this product?