PDA

View Full Version : [Question(s)] Which Python and wxPython versions for Windows for PyPose?



siempre.aprendiendo
08-10-2014, 04:28 AM
Using Linux Mint apt-get, as read the help pages, PyPose worked from the first time. But I also would like to could use it with Windows.

I have tried several 2.x Python versions (2.6, 2.7,...) and its wxPython, but an error appears when executing PyPose.

Which Python version combination do you use for Windows?

Thanks!

tician
08-11-2014, 05:34 PM
ArduTank had a rather long thread (http://forums.trossenrobotics.com/showthread.php?7011-NUKE-issues) trying to get it working on windows, but the latest version did not seem to work without throwing some sort of exception in the legIK() function of lizard3.py.


The only thing really springing to mind for causing legIK() to continue to throw exceptions after correcting the radToServo() typo is mixing 32-bit and 64-bit python and packages, or just win7 being crap. If it were my machine, I would archive all the existing arduino projects and libraries, then purge and reinstall arduino 1.5, python-2.7 (https://www.python.org/ftp/python/2.7.8/python-2.7.8.msi) (32-bit), pyserial-2.7.win32.exe (http://sourceforge.net/projects/pyserial/files/pyserial/2.7/pyserial-2.7.win32.exe/download) (32-bit, Python-2.7), wxPython-win32-py27 (http://downloads.sourceforge.net/wxpython/wxPython3.0-win32-3.0.0.0-py27.exe) (32-bit, Python-2.7), and the vanadium-github arbotix libraries inside the arduino sketchbook.
I am thinking that I had purged all python packages from the Win7 64-bit machine in the lab then reinstalled all the newest packages available when I added this tutorial for the OpenCM-904 and PyPose (http://www.robotsource.org/bs/bd.php?bt=forum_CM9DeveloperWorld&bt_id=586), so tracking down the versions released at that time might work if nothing else does.