PDA

View Full Version : [Question(s)] Dynamixel SDK RXTIMEOUT Error - Visual Studio -USB2Dynamixel - XL-320



evilmime
11-26-2014, 12:25 AM
I am having trouble communicating with my dynamixel xl-320.

Current setup is using the windows sdk and visual studio 2013, communication via usb2dynamixel by replacing the smaller connector on the xl-320 to one that is compatible with the Usb2Dynamixel.

I can control the xl-320 with no problems at all using the dynamixel manager in roboplus. I can also compile the sdk examples and connect to the usb2dynamixel with no problems. But when trying to run the READ_WRITE example with the xl-320 (after updating the control table addresse to match the xl-320's specs), I continually get a RXTIMEOUT error.

One obvious possibility is the baud rate of the xl-320 not matching what I'm trying to communicate with, but I've checked and double checked that they are the same. I manually set the baud rate to 9600 in the dynamixel manager, and then tried the following:


#define DEFAULT_BAUDNUM 207
dxl_initialize(DEFAULT_PORTNUM, DEFAULT_BAUDNUM)


but when I try executing the following code I still get a timeout error


dxl_write_word(DEFAULT_ID, P_GOAL_POSITION_L, GoalPos[index])

I then manually set the baud rate back to 1 Mbs and changed DEFAULT_BAUDNUM back to 1, but am still having the same issue.

Any ideas on what could be going wrong?

tician
11-26-2014, 12:56 AM
The XL-320 use the dxl2.0 protocol, not the dxl1.0 protocol available in the dynamixel sdk. You will have to modify the sdk to get it working with the XL-320 or any Dynamixel Pro servos.

glalonde
12-11-2014, 07:15 PM
I'm doing this for linux at least if you're still working on it:
https://github.com/jefesaurus/DynamixelSDK2.0

Currently works for pinging/reading/writing to XL-320's using USB2AX

To get it to work on windows, you would probably have to swap in the windows versions of dxl_hal.c/h which are in robotis's repos somewhere.