View Full Version : [Question(s)] Motor Connection Issues

04-23-2015, 10:17 AM
Hi All,

We’ve completely assembled our robot and are running into a problem getting the motors to function.

Before assembly, I used the dxl_monitor to set the servo ids individually. All went well and I was able to write to register 30 without issue. The pi was used to complete this setup step.

We then completed the robot assembly guide. I can ssh into the pi, start the dxl_monitor, but all motors fail to connect. I’ve tried unplugging all motors from the ArbotiX Pro and reconnecting a single one. This single motor also fails to connect.

Substituting the pi for the edison give me the same results.

Any ideas?



04-23-2015, 10:53 AM
Hi Joe,

In DXL monitor, can you run the command

on all

then so a scan and see if any of the servos show up?

04-23-2015, 12:21 PM
Thanks kgranat. I ran the command `on all`, there's no output. The scan show's 20 servos and their checks, all read FAIL. Any other ideas?

04-23-2015, 12:54 PM
Would it be possible for the arbotix pro board to go bad? I've noticed 3 buttons on it, (reset, mode, and start) but aren't sure what they do. I haven't found any documentation on this board, I can't even find it for sale.

04-23-2015, 04:59 PM
The ArbotiX Pro boards are a brand new board, we'll have them up for sale later next week. We haven't had any problems with them 'going bad' yet, but it is a brand new product.

Do you have access to a windows PC? If so, can you install RoboPlus/ the DYNAMIXEL wizard and see if you can connect to a single servo? Instructions can be found here

Also, can you make sure that the TTL jumpe is in place? There should be a black jumper on 2 of the pins on the board near the DYNAMIXEL ports that says 'TTL'.5873

04-24-2015, 02:06 PM
Thanks for your help.

I found a Windows machine I can use and followed the instructions from the link you provided. I'm having what appears to be the same results I posted above with the pi and edison. Connection to the board works just fine, but none of the servos can be identified. I've tried multiple servos and multiple positions on the board.

The TTL jumper matches the position from the image you provided.

04-24-2015, 04:11 PM
When you connect to the ArbotiX Pro in the DYNAMIXEL wizard and you tuen power onto the dynamixel chain, do the servos LEDs blink?

Can you send me an e-mail ([email protected]) with your order number? We can work on getting the board back from you for inspection and getting you a new board.

04-27-2015, 09:09 AM
Sorry, no blinks from the LED.

Thanks again for your help. I'll dig up the order number and shoot you an e-mail.