View Full Version : Streaming camera view?

04-30-2015, 04:53 PM
Is there a program in the project that places what the camera sees onto a screen? -thanks, edmay

05-01-2015, 01:22 AM
We don't have any official support for that yet, but we're hoping to work in in when we start working on vision tracking for the robot.

I know that there are plenty of video streaming programs for linux, though I'm not sure the best one for the raspberry pi.

05-01-2015, 08:32 AM
I have not played with it yet, hopefully soon. Quite awhile ago, with the help of KevinO I was able to setup remote viewing of a USB camera. This was back when I originally was playing with an earlier RPI on the PhantomX.

I am still a little hazy on what I did back then, but some hints are scattered on the old forum threads like: http://forums.trossenrobotics.com/showthread.php?6040-PhantomX-controlled-by-a-Raspberry-Pi&p=56769#post56769

Which gave a link to one of things I tried: http://www.instructables.com/id/Create-an-internet-controlled-robot-using-Livebots/step5/Get-the-webcam-streamer-for-Raspberry-Pi/

05-01-2015, 10:20 AM
On the RPi I used to use mjpg_streamer and on the Edison I've been using edi-cam.

I'm just waking up and on my phone but a Google search for either of these should provide lots of useful information.

Edison: https://github.com/drejkim/edi-cam
RaspberryPi: http://sourceforge.net/projects/mjpg-streamer/

05-01-2015, 11:14 AM
Thanks r3n33...

FYI - I decided that while waiting on another PuTTY thread for some ROS requirement to build, I would go ahead and install
mjpg-streamer... I downloaded the sources... The compile failed. Found fix and more info on the web site:

05-04-2015, 01:53 PM
I've been having pretty good luck with motion. You can find a tutorial here - http://www.instructables.com/id/Raspberry-Pi-remote-webcam/

I ran sudo apt-get update before hand and was able to follow the tutorial.

05-04-2015, 04:29 PM
JoeLongstreet, whats the best framerate you've been able to get? It was pretty bad for me, but I might have had some bad settings.

05-04-2015, 04:33 PM
@kganat, yeah the frame rate is really low. It's at maybe 2fps or so.

And for some reason I wasn't able to get the included camera to work. I just used an old webcam and taped it to the robos head.

05-05-2015, 01:07 PM
JoeLongstreet, whats the best framerate you've been able to get? It was pretty bad for me, but I might have had some bad settings.

Can you tell us more about the camera shipped with the HR-OS1? I was able to get my logitech webcam to stream a nice video to a web browser via mjpg-streamer, but every setting on the shipped one doesn't work. (and yes: I switched the two middle wires as you suggested.

Ed May

05-06-2015, 07:44 AM
@edmay, see my second comment - I wasn't actually able to get the shipped camera to work. I'm using an old logitech webcam that i just taped to the robot.

05-06-2015, 02:45 PM
@JoeLongstreet and @Edmay, can you tell me a little bit about your setup with the camera?

-Are you plugging the camera in straight to USB or are you using our wiring diagram / 4-pin connectors?
-If you used our wiring diagram, did you initially have the camera plugged in according to the original (incorrect) assembly guide?
-Can you get the webcam to work with any other system?

05-07-2015, 08:06 AM
I am using your wiring diagram with the NEW green red switch and the 4-pin connectors.
I did have the camera plugged in with the old wiring diagram initially (could it have downloaded the incorrect drivers?)
I just plugged it into my windows machine and I was able to see images from the camera

Hope this helps,
Ed May

05-08-2015, 12:11 PM
Edmay, can you e-mail me your order number?
[email protected]

05-18-2015, 01:24 PM
Seems there is a bug in the code for web cams. Looks like they will fix it in next release. I see a fix out there just not tried it out myself yet.
Digging around various forums I found the following links to information which may be of help:

https://bugs.launchpad.net/ubuntu/+sour ... ug/1362358 (https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1362358)
http://www.mail-archive.com/linux-media ... 80158.html (http://www.mail-archive.com/[email protected]/msg80158.html)

"Apparently from the first link above, this is not a bug in the driver but a bug in code that uses the driver. It seems there was a bug in the driver that applications such as guvcvideo were using and now that the bug is fixed, they stopped working. I figure the input_uvc.so module probably has this issue too and needs to be fixed."

05-19-2015, 07:30 AM
I really hope he meant the green white switch on the wires.:confused:

06-07-2015, 04:12 PM
Sweet the shipped camera works with gucview in Unbuntu-Mate and the Hros1-Framwork complies and everything runs and compiles ok.
Frame rate is low, but at 320-240 it runs ok. Oh nice I used get install to install opencv on Unbuntu-Mate and the camera and color
tracking work nice and the frame rate is not so bad, i'll be:cool:.

09-30-2015, 10:00 AM
"We don't have any official support for that yet, but we're hoping to work in when we start working on vision tracking for the robot."
Will you all be working on this any time soon? It is a major part of the robot kit, just saying.

10-23-2015, 04:37 AM
This link works, but there is quite a delay in the images because the images need to be transferred to another webbrowser via wifi.