PDA

View Full Version : Odroid C1 Ubuntu 14.04 and wicd and IPv6 issue?



KurtEck
05-02-2015, 10:36 AM
I am not sure if this Is Odroid specific or mainly wicd? But on my Odroid C1, I thought I would try out an image (http://forum.odroid.com/viewtopic.php?f=112&t=11994&sid=2bb0b8f2a9b6ed165c00d8784252320e) that one of the main users setup for ROS with OpenNI and pCL. It is built around Ubuntu 14.04.2?

Before this I ran the official build (http://forum.odroid.com/viewtopic.php?f=112&t=5234) and my wifi networking was running fine.

But with this ROS version, they stripped down the build, changed which screen manager was used and in addition switched to wicd as their network manager.

With this image none of my wifi adapters work, including the Odroids most recent one (v4). The Gui when I try to connect complains about invalid password, which I know is correct. But looking at dmesg it looks like it is erroring out trying to use IPv6. Note: the member who setup this image only uses wired network, which does work for me... But for Robot I want wireless...

My strong guess is that my network is not setup for IPv6 and probably only support IPv4. My home networks is a little more complex than normal, with microwave connection to tower, that goes to my main router (Netgear Prosafe), which connects up to several places in my house and does the DHCP. My secondary router (netgear wndr3700) connected to Prosafe which handles the wifi... So not sure in which of these parts do not support IPv6...

I tried removing wicd and try to go back to network-manager, but network manager was still installed. Tried copying some of the network configurations from working image to this and still no connection.

So question is, is there an easy way to disable IPv6 and have it only use IPv4, or should I attempt to figure out if it is possible to configure my network to support IPv6?

Thanks
Kurt

tician
05-02-2015, 11:05 AM
Copying files from the working image, or retyping the settings using the network-manager gui? I've never been able to get copied or manually created configuration files to be recognized by network-manager. After using the gui to create configuration files, I've then been able to modify those files to change the settings and still have everything work, but they have to be created by the gui first.

KurtEck
05-02-2015, 05:15 PM
Thanks, yes I have not had a lot of luck this way either. When I was using the BBBk I did have some luck hand generating the files.

But my guess is that there probably is some system setting that controls IPv6. I have seen several different things up on Web talking about this, but still not making much sense of it. I think some have done it by disabling something in the boot settings.

Kurt

KurtEck
05-02-2015, 06:36 PM
I got the wifi to work :D :D :D

I first tried to disable IPV6 in ubuntu, by following:
http://askubuntu.com/questions/440649/how-to-disable-ipv6-in-ubuntu-14-04

Still appeared to try to use IPV6 and failed. So I did some searching around and found:
https://www.raspberrypi.org/forums/viewtopic.php?f=91&t=9132&start=32

So I simply hard coded my network stuff into /etc/network/interfaces
When I rebooted my wifi was up and running

Kurt