View Full Version : [Interesting] RPI3 with the HROS1-Framework.

03-19-2016, 10:07 AM
I have the rpi3 running the HROS1-Framework with the rpi 2016-02-26 image from https://www.raspberrypi.org/downloads/raspbian/ Use raspi-config to resize and boot without desktop and https://github.com/Interbotix/HROS1-Framework/wiki for all Debian Dependencies, get clone the framework at (git clone https://github.com/Interbotix/HROS1-Framework.git) and everything compiles and runs.
The camera code should be recompiled to keep the camera upright for vision/blob tracking
Re: Camera / Vision Processing (within the HR-OS1 Framework)
Edit: If you look down at line 408 (https://github.com/Interbotix/HROS1-Framework/blob/master/Linux/build/LinuxCamera.cpp#L408) it's flipping the video. Comment that line, compile, and it will work in it's original orientation.
This is the Linuxcamera.cpp code in the main build, just edit it and the re-compile sudo make clean and make all.
There is a method of upgrading your existing image, I'll will try it out today and see, if it works it might save hours of rebuilding work.:veryhappy:
(Note) I am using the rpi3 as a direct drop in replacement for the existing rpi2.

03-19-2016, 12:02 PM
How to transfer your microSD card.
The best way to use your new Raspberry Pi 3 is with a fresh Raspbian or NOOBS installation.
To use an existing Raspbian microSD card with the Pi 3, you’ll need to make a modification.
In your older Pi, boot Raspbian and open a terminal. Type the following command:
sudo apt-get update sudo apt-get dist-upgrade
Shut the Pi down:
sudo shutdown -h now
Transfer your microSD card to your Pi 3 and your existing operating system will boot. Finally, make sure you’re up to date:
sudo apt-get update sudo apt-get upgrade
and all should be well. I just upgraded one of my ros spider bots and everything thing is really nice maybe not 35% nicer but a whole lot faster, and saved me about 8 hours of compiling. Double yea!:veryhappy:
Note. I did note a odd behavior with the Headtracking demo. The first time you run make all, it has a error, but if you then run sudo make clean and then make all over, it compiles correctly and runs OK fine.

03-20-2016, 03:15 PM
Hum, Ok found a snag may need some help with this one. The Bluetooth is not loading correctly and is not finding the Bluetooth dongle, maybe need to dive in as the built in Bluetooth maybe be causing the problem and may be the answer. However the Upgraded SD works fine. I am thinking there is a Bluetooth issue with the new rpi3 image or something. Getting there. EDIT( A new image 2016-03-18 is out.
I noticed on different forums that Bluetooth is having issues, seems to be a common thing. I can turn it on manually on the Desktop but when I reboot to command line the Bluetooth stops working. May need to lean more about bluetoothctl and sysmtctl :sad:)

03-30-2016, 02:39 PM
Please help. Tried both Raspberry Pi 3 with a fresh NOOBS installation, as well as method using existing Raspbian microSD card with the Pi 3 with suggested modifications. Neither worked. When compiling in HROS1-Framework/Linux/build process terminates when attempting to compile ps3 controller and Bluetooth. Compile aborts and fails to create lib directory with Darwin.a

03-31-2016, 04:57 AM
Hum. Now I got a lot farther than that. Sounds like maybe you need to load up synaptic and then make sure you got the bluez and the bluez- utilities. I noticed some repository issues with some updated SD's as well. All in all this is not going smoothly at all. But you should have been able to compile the framework with there latest image as it compiled for me. I also added the AC600 wifi drivers so I can connect at 5Ghz for video and WiFi and it seems to be a huge improvement. I have not done any frame rate testing but video seems to lag much less. (Note. I just re-ran everything and it all compiled for me. Try sudo apt-get install bluez bluez-firmware) see if this is missing?

05-16-2016, 09:07 AM
hum there is a new image for the rpi-3 with sd card copy facility built in and some Bluetooth fixes, I must try and see if this is the fix I was looking for here.

12-09-2016, 01:58 AM
RPI3 Support added with latest image, all dependencies included. https://sourceforge.net/projects/hros1raspberrypiimage/files/Raspberry%20Pi/

Pairing works with the integrated bluetooth but requires a different setup process than before, detailed here: