PDA

View Full Version : HR-OS1 shaking when standing



jgrosso
06-18-2016, 11:59 AM
My HR-OS1 lurches back and forth when it's standing during ps3_demo. If I pull its torso back slightly, the issue stops (and I can walk), but if I stop walking again the issue often restarts. Unfortunately, I'm having other problems and so can't post a video, but its torso rapidly shakes back and then forward again and again until manually corrected.
Should I change settings in the walk tuner, tighten screws, ...?
Thanks for the help!

r3n33
06-18-2016, 02:07 PM
Sounds to me like the balance gain might be just a little too high. I'd definitely check the screws since there is always one or two that find a way of coming loose over time.

In walk tuner you can try adjusting the "Balance knee gain" and "Balance ankle pitch gain" by -0.01 until the issue is improved.

Alexi
06-24-2016, 02:21 AM
I could observe the same behavior during the ps3_demo! Did anyone find a solution yet?

Also I have the problem that I don't know how to stop the demo, since the stop_ps3_demo program does not exist as stated in the tutorial. The only way I can stop it is to turn it off. How do you make it stop?

r3n33
06-24-2016, 10:41 AM
I could observe the same behavior during the ps3_demo! Did anyone find a solution yet?

Also I have the problem that I don't know how to stop the demo, since the stop_ps3_demo program does not exist as stated in the tutorial. The only way I can stop it is to turn it off. How do you make it stop?

Did you try my suggestion? The adjustable parameters in walk_tuner are used in any project using the motion manager and walking module from the framework including ps3_demo.

You are correct about the stop_ps3_demo script being missing. I'm actually not sure why and don't see that I've ever had a copy in my fork of the OS1 framework. However I believe you can call 'sudo killall demo' or make a script that does this for you to stop the ps3_demo and prevent you from having to turn the robot off.