PDA

View Full Version : [Question(s)] PhantomX Reactor Robot Arm has all red LEDs on the servos and green LED on power supply flashing



markshav
10-25-2016, 10:08 AM
My PhantomX Reactor Robot Arm has all red LEDs flashing on the servos and green LED on power supply flashing and I cannot talk to the arm via Arduino. Things used to work fine and I expect the Arbotix-M board is not working, maybe it needs a reset? I tried power cycles and let things cool down over night (it was never hot but just in case) and the arm worked find before so its not a tension issue or heat issue.:(

I removed the wire from the Artbox-M to the first servo and the flashing on the power supply stopped. I then moved each wire one by one to see if any servos were bad and it did not matter as once any servo was attached the flashing resumed.

Has someone has seen this before? Is there a way to reset something? (I did push the reset button on the Artbox-M and held it down for 30 seconds all that stuff too).

Thanks!

KurtEck
10-25-2016, 12:22 PM
Red flashing on Servos is usually an indicator of some form of error.

When you say you can not talk to Arm, have you tried simple query packet to the different servos.
For example in cases like this I would try to read Address 0x11 to get the Alarm LED bits to get an idea of what the error is.
And likewise Address 12 to get the shutdown status...

You might try some of the Standard Robotis programs.

I often use my own hacked up test program: https://github.com/KurtE/AX12_Test
But it relies on being setup to use my updated version of the Arbotix libraries. Also relies on my BioloidSerial class, which is also up on github.

Other things I would test, include:

Use a meter and check the voltage coming out of your power supply, to see if you are still getting 12V. I would also probably check some places on the board to make sure you are getting +5v and 3.3v... Would also check power/GND pins on the AX12 buss to make sure 12v. Would check servo wires to make sure there is no obvious place it got pinched, which caused short. Would check resistance on Servo wires to make sure no dead short.

Can you reprogram your Arbotix-m?

Do you have a spare servo to plug in and try? Does it blink Red as well?

markshav
10-25-2016, 12:47 PM
I read through your ideas and I got the arm to fire up (!). I took out the wires going from the first servo and just keep the one coming in from the Arb. I waited a few minutes and things corrected.

Next I will check all the wires my guess is I can trace that down. Thanks for moving me a long, I think I did not wait long enough between power cycles when I tested the wires yesterday, it takes a few seconds for things to clear up.

Just a note but its hard to get wires/servos in the Rector so I ordered Pincher too today as it looks easier to work with during development it as its seems more open and then maybe when closer to production go to the Reactor, just some feedback no complaints. The Reactor is very strong which is why I started there.

markshav
10-25-2016, 05:40 PM
My custom software will now talk to the arm but Reactor Test does not see the servos. Still debugging, one wire may have been loose not sure yet. The arm is erratic when it powers own too.

I am going to see if I can get https://github.com/KurtE/AX12_Test to help next. Just FYI in case someone else gets the same error I did (all leds flashing including the green one on the power supply)

markshav
10-25-2016, 05:52 PM
Hi Kurt, ax12Serial.h is not easy to find, it seems to be one of your own files?

KurtEck
10-25-2016, 05:58 PM
https://github.com/KurtE/BioloidSerial

markshav
10-25-2016, 06:48 PM
Thanks, I rushed past it (looked in Kurts_AX12_Test_Use_Serial and moved on too fast). I think I am getting frustrated and rushing.

Anyway, and I need a break :) , but I took nearly the entire arm apart to get at all the servos and I just cannot get the basic apps to see them by directly connecting to them per the Learn tutorials. Like AXSimpleTest, and followed the initial directions. I had someone else review the wires also -- they said it looks good. Going on Day 3 with this tomorrow.

Could it be the controller? I did order a new controller, and a different arm (Pincher). Maybe I should just wait for that to arrive, but I hate to waste this nice Reactor. I want to get it going again. I did not check the voltages yet either, still my todo.

markshav
10-25-2016, 10:41 PM
Kurt, I just noticed I am using your code extensively (interbox armlink serial), just saw your name in the header. Great to see.

markshav
10-26-2016, 11:56 AM
update: the robot fired up this AM and seem to work just fine, partially assembled, then it stopped again. Maybe I bumped something, not sure yet. Since then I ran the KurtE test software (thanks) and nothing is found on the arm (cmds 4, 5 and 9 return -1 and/or FFs). I the power supply is coming with 12.4v dc, the 3x 3-Pin DYNAMIXEL Ports (TTL) is 12v dc, D23 is 4.7v so power seems fine. Tested the cables again seem ok. Just an update as I am going to chat with a support person today too. There must be something subtle I am just missing.

tician
10-26-2016, 01:04 PM
How large is the power supply? 12V 5A or 12V 10A? The fact that the LED on the power brick itself starts flashing indicates the issue is something power related. Do the same servos work with another 12V power supply (rated at least 3A)?

markshav
10-26-2016, 01:24 PM
Its 12V 5A. I will try another power supply tomorrow too (stuff is being shipped). And thanks for the input.


I should note that after adjusting all the wires and related connections the flashing LED on the power supply no longer occurs, same for the LEDs on the arm. I am going to try a new controller tomorrow to see if that maybe got taken out some how, as you note if the power was flakey for some reason maybe something not so good occurred there.

I checked the voltage from the power supply and it seems ok, and this AM the arm worked great for a few minutes then is stopped again


These arms move around a lot and one bad wire, maybe not even visible could be a problem too I expect. Maybe I will need to replace all of them at some point too, I am going to chat with support soon, and change the card before I order a set of cables.


Thanks for the input

markshav
10-26-2016, 01:38 PM
After rechecking all the wires and connections the green flashing on the power supply stopped yesterday, same for the red LEDs on the arm. Maybe this initial problem damaged the controller, not sure. I do have more parts coming in tomorrow and I can try a different power supply and card. I am using the 12V 5A right now.

KurtEck
10-26-2016, 03:19 PM
Sometimes subtle in the wiring, like where a wire gets pinched and either cut (no connectivity) or insulation is removed and depending on bend or the like can cause intermittent short. If you have any extra cables, I would be tempted to hook it up with different wires and see if that works. Would also probably try running with just the first servo and see if that works, if so add 2nd...

markshav
10-26-2016, 04:49 PM
I going back to as basic of things as far I can. I am running the Dynamanager with server 1 and DM says "No ArbotX found" Then tried servo 8, same thing. Tried a new wire same thing. Did see an LED red flash at power on as expected. Double checked jumper on card and USB wires. I am hopeful the new card will fix this. It sure seems to be narrowed down to that, but will hopefully know more tomorrow. And thanks again.

markshav
10-27-2016, 04:29 PM
I installed a new board and I am able to talk to the servos again. Now resetting the IDs but and I am hopeful it will all come together once I reassemble. All I can assume right now is the card shorted out. Thanks for helping out and I know a lot more know about trouble shooting and that is great.

markshav
10-27-2016, 07:25 PM
reassembled and all works, good to have it back! and thanks for the pointers