Search:

Type: Posts; User: KurtEck; Keyword(s):

Page 1 of 13 1 2 3 4

Search: Search took 0.03 seconds.

  1. Question(s) Re: Dynamixel XM430-W210-T bricked after firmware update

    Earlier was going to suggest that you ask up on Robotis... But saw you did and so responded earlier there.

    Personally I am not liking that Robotis is now punting to you must use on U2D2 to do...
  2. Re: Dynamixel XL340-W250-T with only OpenCM9.04

    Yes you can control XL430 servos using OpenCM9.04 board without the OpenCM RS485 expansion board.

    I have done it in the past using external power hub, where I hacked up a cable to adapt from...
  3. Question(s) Re: OpenCM sketch upload problems on virtualbox

    Also OpenCM IDE is no longer being maintained. I would suggest updating to use the Arduino IDE and install their board install...
    ...
  4. Re: Open CM9.04 - Anyone had luck programming using the Arduno IDE?

    Glad you have it working. I did go ahead and raised a new issue up on the Robotis OpenCM github project.
    https://github.com/ROBOTIS-GIT/OpenCM9.04/issues/89
  5. Re: Open CM9.04 - Anyone had luck programming using the Arduno IDE?

    First off PJRC: as 1.8.10 only came out yesterday, there is a new beta up on the PJRC forum for support for 1.8.10
    https://forum.pjrc.com/threads/57609-Teensyduino-1-48-Beta-1

    OpenCM/OpenCR - It...
  6. Re: Open CM9.04 - Anyone had luck programming using the Arduno IDE?

    I believe that Arduino now installs on ARM 64 setups. I believe this has only been since 1.8.9...

    I Know that PJRC has come out with installer for ARM64.


    I know at one point I had it sort...
  7. Replies
    4
    Views
    874

    Question(s) Re: Using Dynamixel AX-12 A

    As @jwatte mentioned, it could be that the servos are overheating and shutting off.

    If you let the setup rest for a hour or so, does it work again?

    If it still fails and or works a bit and...
  8. Replies
    12
    Views
    1,525

    Project Re: Hexapod ROS revisited

    Hi Kevin,

    Hope things are going well! Are you currently actively playing with the hexapod_ros code? The last changes I noticed where dated back to December?

    What I have been thinking about...
  9. Replies
    12
    Views
    1,525

    Project Re: Hexapod ROS revisited

    All of the above are valid options.

    However personally I would sort of shy away from 1. or 2. - They are workable and I have done both. Although I have not yet adapted them to ROS...

    3. - As...
  10. Question(s) Re: Can I stop Motion Index (Number) before the motion finish all the step?

    I was going to suggest, that you might get more of a response up on the Robotis forums, but, I see you have already posted there....
  11. Replies
    12
    Views
    1,525

    Project Re: Hexapod ROS revisited

    I keep meaning to get back into ROS. I now have a Turtlebot3 (actually sort of two of them) and I did go through some of the stuff.

    But my next step is to then go to ROS2.

    And then I would...
  12. Replies
    3
    Views
    876

    Re: 2 USB Connections on Teensy 3.5 or LC

    Hard to say.

    If you are simply wanting to output some debug information from a Teensy such as a 3.5 to the PC without using the main USB connection.

    I will then typically use some form of...
  13. Replies
    26
    Views
    8,187

    Re: PhatomX with XL430-W250 servos

    I am getting ready to start playing again with this. But while doing so, I am probably going to redo a lot of what I was doing with it in the first pass of the conversion.

    In the first pass, I...
  14. Replies
    26
    Views
    8,187

    Re: PhatomX with XL430-W250 servos

    I need to get back to it.

    I was sort of out of it for awhile, recovering from surgery... And have been busy with helping with the Teensy 4 beta stuff, which should hopefully be released soon.
  15. Replies
    128
    Views
    45,980

    News/Announcement Re: The Robotis TurtleBot3

    Also wonder if any of you have tried to run your RPI 3 or 4 using SSD Drives instead of SD Cards?
    Like for example what is described in:...
  16. Replies
    128
    Views
    45,980

    News/Announcement Re: The Robotis TurtleBot3

    Sounds Good - I just received a 2gb board, have an SD Card, and wall wart power... But don't have right HDMI cable... Should arrive later today or so.

    Trying to decide to try Raspian or Ubuntu.
  17. Replies
    6
    Views
    3,452

    Sticky: Re: Project Khepri - MX 106 hexapod.

    Pretty Cool! Looks like you are having some fun!
  18. Thread: Malum IK

    by KurtEck
    Replies
    58
    Views
    10,580

    Re: Malum IK

    I will be interested as well on how well the MacroFab works, especially for small runs... Like probably < 5...

    I think my first T4 breakout board, that I had Seeedstudio fabricate arrived...
  19. Replies
    4
    Views
    1,638

    Question(s) Re: AVRDUDE ERROR - arbotix board

    Note: I have not used an Arbotix board for a long time now... Now mostly use (OpenCM 9.04, OpenCR, Teensy 3.x (soon Teensy 4) But:

    Is this a new board or one you have programmed in the past?
    ...
  20. Replies
    2
    Views
    1,231

    Question(s) Re: Using Bioloid Library With Servo Modes

    Never tried it... Don't have MX servos... Mostly in past AX12s and now XL430-w250...

    But Bioloid library. I don't think the functions like setNextPose, or loadPose do anything to set modes.
    ...
  21. Question(s) Re: Dynamixel AX-18A ignores commands with Arduino

    Hard to give any advice as there is very little data to go on.

    Example how are the servos connected to the Arduino? Which Arduino?

    What code? Are you using some libraries? Which one? Do...
  22. Replies
    4
    Views
    1,181

    Re: MX-64 bricked after update

    Yikes!

    I don't have any MX servos so not much help...

    I am sure you tried all of the tricks of trying to get it to reprogram. Like only plug it in, when it the Dynamixel Manager is ready to...
  23. Question(s) Re: MacBook Pro - USB desactivated when plugn FTDI-USB cable

    Yes the next thing I would try would be to use a powered USB HUB.

    I would also try plugging the FTDI cable into something else to make sure it's working.
  24. Thread: Ax12/18 pid

    by KurtEck
    Replies
    9
    Views
    4,750

    Re: Ax12/18 pid

    I am not sure are you asking the differences between AX12a and AX18 or to MX-28????

    Some of these time answers can be found in the emanuals...

    http://emanual.robotis.com/docs/en/dxl/ax/ax-12a/...
  25. Question(s) Re: Dynamixels AX-12A on OpenCM 9.04 + OpenCM 485: how to send instruction packets

    Look at the Expansion board schematic: http://support.robotis.com/en/baggage_files/opencm/schematic1___opencm_485exp.pdf

    You will see that the TX3/RX3 connect to DXL buss through some level...
  26. Thread: Malum IK

    by KurtEck
    Replies
    58
    Views
    10,580

    Re: Malum IK

    I don't have any MX servos (unless you count the MX12w I have around here somewhere) so can not say very much... But, If I run R+ Manager 2...

    And choose Dynamixel as product it shows support for...
  27. Replies
    26
    Views
    8,187

    Re: PhatomX with XL430-W250 servos

    @jwatte - I have not played as much with host talking quickly with large amounts of data through the OpenCM board.

    I have tried to fix some of the latency issues of the OpenCM board talking back...
  28. Thread: Malum IK

    by KurtEck
    Replies
    58
    Views
    10,580

    Re: Malum IK

    Hi @jwatte,

    Wonder if it maybe was a protocol2 version of firmware?

    Have you tried talking to it using the R+ Manager?

    Or maybe try the Dynamixel Manager 2 beta?...
  29. Replies
    26
    Views
    8,187

    Re: PhatomX with XL430-W250 servos

    Yes you would need to cross the RX/TX pins for RPI3... Plus you need a common ground between the two boards

    Code wise not sure which code base you are using, but if you are using for example if...
  30. Thread: Malum IK

    by KurtEck
    Replies
    58
    Views
    10,580

    Re: Malum IK

    @jwatte - Cool chip - May have to try that one out... I have used two different chips with one (125/126?) which worked... I also used a chip similar to the one you mentioned, but it was larger as if...
  31. Question(s) Re: Can't connect the servo after input voltage error

    I am/was going to suggest asking up on Robotis forum, looks like someone asked similar one:
    http://en.robotis.com/service/forum_view.php?bbs_no=2407407&page=1&save_sca=&sca=&save_stx=&stx=&sfl=...
  32. Replies
    5
    Views
    1,470

    Re: Dynamixel MX-28 no longer turning

    Maybe something is damaged in the servo. I had something go wrong with an OpenCM9 (or was it the OpenCR board) which have both been repaired, which I think caused a spike on the DXL buss and it...
  33. Replies
    5
    Views
    1,470

    Re: Dynamixel MX-28 no longer turning

    I would probably recommend posting up on Robotis Forum: http://en.robotis.com/service/forum.php It may turn out your servo is damaged and you need to do an RMA...

    My normal suggestions would be...
  34. Replies
    16
    Views
    6,569

    News/Announcement Re: Turtlebot3 with Openmanipulator

    What does not compile? And Where? i.e. is there an issue building for Arduino stuff for the OpenCR board or a problem with ROS builds?

    Again I would probably first post up on Robotis Forum to...
  35. Replies
    26
    Views
    8,187

    Re: PhatomX with XL430-W250 servos

    Quick update: Actually more notes to myself, @jwatte (and others).

    I now have a hacked up sketch, with a second hacked up copy of your flyskybus.h file, which I have hacked up to run on Serial1 on...
  36. Replies
    26
    Views
    8,187

    Re: PhatomX with XL430-W250 servos

    Thanks, I will play with this some.

    Trying to decide how I will do it on OpenCM board. For a test case I might hook up SENS line to Serial1 (DXL ttl pin), which is more or less free if I use...
  37. Replies
    26
    Views
    8,187

    Re: PhatomX with XL430-W250 servos

    @jwatte - Thanks again.

    Curious have you played at all with the bidirectional communications? I know you mentioned they are pretty limited on what information you can return,

    I saw saw some...
  38. Replies
    26
    Views
    8,187

    Re: PhatomX with XL430-W250 servos

    Thanks @jwatte,

    I know the receiver and transmitter are talking now as when I plugged it in to 3.3v, the main unit complained of low battery... And the receiver had on it marked 4 to 8.4v.. So I...
  39. Replies
    26
    Views
    8,187

    Re: PhatomX with XL430-W250 servos

    @jwatte - The RC receiver arrived. Now to figure out how to set up the receiver for IBUS. So far I have seen a video looking like you hook up wire horizontal pins 4-6...
  40. Replies
    26
    Views
    8,187

    Re: PhatomX with XL430-W250 servos

    Quick update: When I ordered the Receiver it said is should arrive sometime between April 3 and 24th... But looked today and it is out for delivery... So should be able to pick it up tomorrow :D
    ...
Results 1 to 40 of 500
Page 1 of 13 1 2 3 4