Search:

Type: Posts; User: corot; Keyword(s):

Search: Search took 0.00 seconds; generated 38 minute(s) ago.

  1. Question(s) Re: How to power AX-12A servos connected to an USB2AX?

    Well... I give up. I assume that the new OpenCM B with only one TTL 3-pin port somehow fails to read from the servos with the existing OpenCM 1.0.2 code nor with DynamixelQ.

    So... as I have now a...
  2. Question(s) Re: How to power AX-12A servos connected to an USB2AX?

    mmm... somehow I knew that I was asking something really easy... and that the obvious answer would make me feel shame :eek:

    Thanks a lot. I can now detect my servos on RoboPlus!

    But... all...
  3. Question(s) How to power AX-12A servos connected to an USB2AX?

    Following the problem I describe on my previous thread "AX-12A servos with OpenCM 9.04: can actuate but not read", I bought an USB2AX to try to solve it, but... RobotCenter is unable to detect my...
  4. Question(s) AX-12A servos with OpenCM 9.04: can actuate but not read

    Hello, I recently replaced my OpenCM 9.04 because the old one got broken. I can again set servos positions, both with Dynamixel::setPosition and PyPose. But read position always return 0xFFFF. After...
  5. Replies
    2
    Views
    4,002

    Question(s) Re: Connect sensors to OpenCM 485 Expansion Board?

    Exactly, the 5-pins ports is exactly what I was looking for. I gave for granted that they used some exotic protocol specific for interfacing with custom Robotis sensors, but as you said they are just...
  6. Replies
    2
    Views
    4,002

    Question(s) Connect sensors to OpenCM 485 Expansion Board?

    Hi all, I have recently replaced my broken OpenCM9.04 by a new working one. All fine, but I also received an OpenCM 485 Expansion Board as a gift, and... honestly speaking, I have no idea about what...
  7. Question(s) Re: Is my OpenCM 9.04 dead? Or do are my AX-12A servos?

    As I though... my OpenCM is broken. I got a new one and works as usual.
    Thanks!
  8. Question(s) Re: Is my OpenCM 9.04 dead? Or do are my AX-12A servos?

    Thank you very much for your fast response. I guess you mean the tosser firmware. I tried with it, but still cannot detect the servos with the Dynamixel Wizard, nor recover the servos firmware (it...
  9. Question(s) Is my OpenCM 9.04 dead? Or do are my AX-12A servos?

    Hi all,

    Background: I have a Turtlebot arm (5 AX-12A servos) controlled with a OpenCM 9.04. It worked fine till last week, when I updated ubuntu to 16.04. Of course the update has nothing to do...
  10. Re: Reuse arbotix ROS stack for a Robotis OpenCM9.04-B control board

    Hello again,

    I have found the problem: MAX_NUM_SERVOS constant on pypose.ino must be equal to the actual number of servos you have. If not, BioloidController::readPose will spam the serial line...
  11. Re: Reuse arbotix ROS stack for a Robotis OpenCM9.04-B control board

    Hi!
    Yes, I use the pypose sketch shipped with Robotis' OpenCM. And for PyPose, I have tried both the Vanadium Labs repo and your fork, with the same result.

    I'm trying to understand how PyPose...
  12. Re: Reuse arbotix ROS stack for a Robotis OpenCM9.04-B control board

    Hi tician, thank you very much again. I have realized that you ported PyPose to use it with the OpenCM and, as a preliminary step before trying to use it on ROS, I'm trying to make it work. As I...
  13. Re: Reuse arbotix ROS stack for a Robotis OpenCM9.04-B control board

    First of all, thank you for your ultra-fast answer!

    I have taken a look to the ros.ino file and, biggest problem I see is that it's not well documented (or at least I cannot find any...
  14. Reuse arbotix ROS stack for a Robotis OpenCM9.04-B control board

    I bet the title is already confussing and even non-sense... sorry, I'm new on low level control boards.

    Well, what I have is a turtlebot arm but instead of the ArtiboX board, I bought the...
Results 1 to 14 of 14