Search:

Type: Posts; User: KurtEck; Keyword(s):

Page 1 of 13 1 2 3 4

Search: Search took 0.01 seconds.

  1. Replies
    3
    Views
    1,392

    Re: Python dynamixelSDK very slow read

    Sorry, I am not a python person...

    My only time I experimented with Python was on a ROS setup, using something like an RPI... And at least at that time ROS with PySerial really had issues. Some...
  2. Question(s) Re: PhantomX Reactor -> USB2AX -> Arm Link ->Processing 3 -> Windows 10 (is this possible?)

    Sorry, did not see this messages until yesterday. Not sure if it was moderated until then.

    There are very few of us up on this forum these days, and I am not sure I can help much, as I no longer...
  3. Question(s) Re: Dynamixel Driver fails to open port for VX300 robot arm

    Actually looks like U2D2 is an FTDI device: On my Ubuntu machine:

    Sorry the text did not cut and paste well on the machine...
  4. Question(s) Re: Dynamixel Driver fails to open port for VX300 robot arm

    Sorry, maybe should backup... First thing I would do is contact trossen support and see what they say... They don't typically monitor or respond to forum So VX300 looks like it is using a U2D2... ...
  5. Question(s) Re: Dynamixel Driver fails to open port for VX300 robot arm

    Sorry I don't know what the Interbotix setup is doing or what library or libraries are in use.

    The /dev/ttyDXL sounds similar to stuff I setup earlier when I was playing with linux SBC boards...
  6. Replies
    2
    Views
    1,927

    Re: This is abandonware

    Sorry I did not see this thread until now.

    I totally agree that the Arbotix board and support are now pretty well abandoned. As you mentioned the last official release was for Arduino 1.0.6...
  7. Replies
    3
    Views
    7,554

    Re: Pi4, Pi3, and Arbotix Pro mini tower

    I have not touched my HR-OS1 for a very long time. As I have mentioned in some other threads, my guess is your issue with either upgrade or RPI4 communications, is either with how the code...
  8. Question(s) Re: Arbotix Pro erratic after apt-get update & upgrade on my RPI3

    Note: about 5 years ago, I was experimenting with controlling the Arbotix Pro using a serial port instead of USB.... Why on one AP the USB connector tore off and took the etch for the port with it......
  9. Question(s) Re: Arbotix Pro erratic after apt-get update & upgrade on my RPI3

    Forgot to mention a few more things, that if it were me, I would be checking.

    I believe the Arbotix Pro uses an FTDI chip to communicate over USB...

    So I would make sure you have an FTDI driver...
  10. Question(s) Re: Arbotix Pro erratic after apt-get update & upgrade on my RPI3

    Sorry my HROS1 has been sitting in dust for several years now. Probably not likely to be resurrected anytime soon.

    But back then I know I had played with a few different processors, like Edison...
  11. Replies
    3
    Views
    3,023

    Re: Dynamixel AX-18As not appearing using U2D2

    Hi Hexapod guy.

    Sorry, to hear you are having some issues. I am sort of rusty on some of this.

    Sometimes hard to know exactly what is happening on your setup.

    I also do not have a U2D2...
  12. Replies
    4
    Views
    23,813

    Re: RC100 data packets

    Sorry I did not see this question back then... Also not sure if you are still up here. Would have suggested to take this up on either PJRC forum and/or Robotis forum.

    Awhile ago when I was...
  13. Replies
    11
    Views
    14,119

    Question(s) Re: Baudrate for dynamixels

    Sorry, again not sure if there is a straight forward answer to this one.

    Things like what servos? X Series would be my guess as AX for example does not go that fast. How many?
    Protocol 1 or...
  14. Replies
    11
    Views
    14,119

    Question(s) Re: Baudrate for dynamixels

    Sorry, I am not the EE type... Probably depends on what wires and the like. Also topography of it...
    Something like the resistance and impedance ... Again EEs can give move info.

    I just know...
  15. Replies
    11
    Views
    14,119

    Question(s) Re: Baudrate for dynamixels

    The main issue, is the higher the baud rate, the shorter the bits are, so the more likely there will be errors... especially when you have a long wire... I usually have stuck with 1MBS, on some...
  16. Replies
    7
    Views
    6,740

    Question(s) Re: RS485 logic level in Dynamixel servos

    Sorry, I am not sure what you are asking. Although I must admit I have not used any of their RS485 version servos. All of mine are TTL level. Also not sure if anyone can answer some of these...
  17. Replies
    6
    Views
    26,972

    Re: OpenCM 9.04 and SPI

    Again it has been a long time since I played with the OpenCM boards... And awhile since I tried SPI library on the board.

    But if I remember there are two SPI busses on the chip.
    If you look at...
  18. Replies
    6
    Views
    26,972

    Re: OpenCM 9.04 and SPI

    Have you asked up on the Robotis website? Not sure how well they are responding these days as I am not currently playing with Robotis stuff...

    Which Arduino? Which encoder... i.e. is your...
  19. Replies
    7
    Views
    8,718

    Re: How to test Dynamixels upon arrival

    I did not always do it... Only if there looks like they have new features or important bug fixes. But with some of their newer servos I tended to update them when I could.

    But sometimes I go by...
  20. Replies
    5
    Views
    29,241

    Re: Discharge rate of LIPO

    I am no expert on this, but my read on this, is you probably can not have too much capacity. The servos will only take as much as they need. Except of course if you do something like short out...
  21. Replies
    7
    Views
    8,718

    Re: How to test Dynamixels upon arrival

    I sometimes just run one of my own test sketches, that does something like: scan at the default baud rate to find any servo. It should find it probably as ID #1.

    I then have my test program,...
  22. Replies
    8
    Views
    9,527

    Re: Questions about powering

    Again others can and have answered this a lot better than I can...
    I have not done the multiple batteries in a very long time. Last time I tried it was with RC servos connected up to an SSC-32...
  23. Re: What are the pros and cons of buying the required number of Dynamixel at the same time? Your experience with Robotis return policy

    Note they do have a warranty


    And I have shipped some stuff to them, and they have not yet ever charged me for fixing a few servos, OpenCR board, OpenCM...

    The only issue I have had with...
  24. Replies
    4
    Views
    18,703

    Question(s) Re: AX12+ servos not recognized/seen

    As you are using all Robotis hardware, you might try asking up on their forums.

    Although my impression is that they may be slow on responding these days.

    Also not sure from your description,...
  25. Replies
    3
    Views
    26,366

    Question(s) Re: Arbotix Pro doesn't recognize MX106T motors

    My guess is that the Arbotix-Pros firmware does not support protocol-2 communications. And if you updated your servos to use protocol 2, then there may be issues with arbotix pro, talking to it.
    ...
  26. Replies
    2
    Views
    6,388

    Question(s) Re: OpenCM 9.04 Freezes when using serial port

    Since you are talking about mostly Robotis products, I would first recommend that you post on their Forum, and/or enter a issue on their OpenCM github project...

    Debugging:

    a) I often will add...
  27. Question(s) Re: In practice, any difference between the XM and XH series?

    Sorry, I have used neither... But your summary is what I have seen mentioned up on Robotis...
  28. Question(s) Re: Weird problem: either all dynamixel AX12's discovered or none.

    When I have seen things like this, it is often a cable, that maybe got caught in a joint and breaks through the insulation

    Or maybe a servo has gone bad. If I get into this state, I try to unplug...
  29. Replies
    2
    Views
    17,092

    Question(s) Re: Xbee Pro on Arbotix M board

    Sorry I just noticed this thread as well as the duplicate...

    My personal suggestions include:
    Use a different board other than Arbotix, which has more support. Like an official Arduino...
  30. Replies
    4
    Views
    17,288

    Bioloid Re: Bioloid Library for OpenCM 9.04

    At one point I think I had a version of the Bioloid library running on OpenCM board.... With my BioloidSerial library which is setup to run on AVR boards, as well as Teensy boards... It is up on my...
  31. Thread: Malum IK

    by KurtEck
    Replies
    69
    Views
    89,526

    Re: Malum IK

    Maybe it is just me, but I can not get to either of your (jwatte and tician) attachments...

    Gives me an error about invalid_attachment...
  32. Thread: Malum IK

    by KurtEck
    Replies
    69
    Views
    89,526

    Re: Malum IK

    Thanks @jwatte,

    I will double check my layout and make sure I did not screw something up in translation, which is highly possible! Or bad soldering...

    As for T3.2/5 you probably don't need to...
  33. Thread: Malum IK

    by KurtEck
    Replies
    69
    Views
    89,526

    Re: Malum IK

    Hi @jwatte -

    I put this circuit into a new board I am playing with, and I am having some issues. I fixed a few issues when I found when I added the circuit, I did some copy/paste of resistors...
  34. Replies
    3
    Views
    7,027

    Question(s) Re: Problems with Phantom X hexapod

    It is somewhat hard to say without seeing pictures and the like.

    Yes there can be sharp edges, which can cause problems, likewise routing the wires, such that they get pulled or the like when the...
  35. Replies
    4
    Views
    7,769

    Question(s) Re: Arduino 1.8.10 ?

    Like @tician, I have not tried it in awhile, but it worked the last time I did it.

    Some things to look out for. I am assuming that you did not install it using Windows apps install, but instead...
  36. Question(s) Re: DYNAMIXEL MX-28 Velocity Mode is Not Working Properly

    Warning I don't have any of these servos or a USB2Dynamixel so take this with a grain of salt. I mostly have AX servos and now several XL430_W250 like servos.

    Have you asked up on the Robotis...
  37. Replies
    5
    Views
    32,590

    Question(s) Re: Dynamanager finds mx-28t but not mx-106T

    Personally I would use a different controller than Arbotix-m as, currently there is almost no support for it.

    Don't know how you are configured. Still back with Arduino 1.0.? or up at or near...
  38. Replies
    5
    Views
    32,590

    Question(s) Re: Dynamanager finds mx-28t but not mx-106T

    My guess is they are using? https://github.com/Interbotix/dynaManager/releases ?

    If it were me, I would probably convert to use something else as I don't believe there is anyone left at Trossen...
  39. Replies
    8
    Views
    29,798

    Re: Dynamixel XL340-W250-T with only OpenCM9.04

    FYI - I don't have a U2D2, So may not be as much help here...

    I assume you are connected up like they show in: http://emanual.robotis.com/docs/en/parts/interface/u2d2/#software

    And if you...
  40. Question(s) Re: Dynamixel XM430-W210-T bricked after firmware update

    As I mentioned, I had an OpenCR boards communication chip fail.
    I was able to demonstrate it, by hooking up a logic analyzer to the output pin, and nothing came out. I then shipped it to Robotis,...
Results 1 to 40 of 500
Page 1 of 13 1 2 3 4