Search:

Type: Posts; User: xenoc; Keyword(s):

Search: Search took 0.00 seconds.

  1. Replies
    26
    Views
    8,181

    Re: PhatomX with XL430-W250 servos

    Thanks guys for the help. I got it working ok using a simple cross connect of Rx and Tx over the serial ports
    RPI3 Tx on GPIO14 (Pin 8) to OpenCM9.04 Rx on A5
    RPI3 Rx on GPIO15 (Pin 10) to...
  2. Replies
    26
    Views
    8,181

    Re: PhatomX with XL430-W250 servos

    I'm developed the Python code running on a RPI3 to emulate the Commander remote control for the PhantomX Hexapod running the Phoenix code modified by Kurt to run on the Open CM 9.04 board. The RPI is...
  3. Replies
    26
    Views
    8,181

    Re: PhatomX with XL430-W250 servos

    I've found the OpenCM904 to be a good substitute for the Arbotix and I'm controlling the Hexapod with the Phoenix code using the Commander with a Xbee connected to one of the serial ports on the...
  4. Replies
    40
    Views
    14,461

    Re: Phantom_Phoenix on OpenCM 9.04...

    Hi Kurt, I got the Pixy camera working okay with the Phoenix code. Initially have trained the camera to track a blue ball and integrated the Pixy output to control the tilt/pan and get the robot to...
  5. Replies
    40
    Views
    14,461

    Re: Phantom_Phoenix on OpenCM 9.04...

    Hi Kurt,
    Thanks I uncommented the section to define the Turret pins and it works fine. I can do the pan and tilt from the Commander in Walk mode 3. It's very smooth. Good coding that I can leverage...
  6. Replies
    40
    Views
    14,461

    Re: Phantom_Phoenix on OpenCM 9.04...

    Hi Kurt,
    Thanks for that post. The Robotis PCB Supports look good. I'll give them a try as I have several boards now which don't have the 1cm spacing. I'm not quite ready to invest in a 3D printer...
  7. Replies
    40
    Views
    14,461

    Re: Phantom_Phoenix on OpenCM 9.04...

    I've migrated from ArbotixM to OpenCM 9.04 for my Hexapod with Kurt's help and generally have been happy with the move. I did it mainly because I wanted more uarts. The ArbotixM is severely...
  8. Replies
    40
    Views
    14,461

    Re: Phantom_Phoenix on OpenCM 9.04...

    Ok thanks for the debug tips. I'll work through it as suggested.
    The Pixy2 Hello world example works fine and I can see output on tracked objects. I'm using the SPI interface as it was the fastest...
  9. Replies
    40
    Views
    14,461

    Re: Phantom_Phoenix on OpenCM 9.04...

    Thanks for the fork and the confirmation. I’m been able to download the hex file ok to the cm904. However I have a new issue. We included some Pixy code in Phoenix sketch. It compiles and downloads...
  10. Replies
    40
    Views
    14,461

    Re: Phantom_Phoenix on OpenCM 9.04...

    I've got a RPI Zero W mounted on the Hexapod now and I can VNC into and upload an Arduino Sketch reasonably reliably (see below) The code works fine on the Hexapod once loaded but it takes several...
  11. Replies
    40
    Views
    14,461

    Re: Phantom_Phoenix on OpenCM 9.04...

    Hi Kurt,
    Thanks for all that info. I've had some success using a RPI 3 with Arduino 1.8.7 installed and the patch supplied by OpusK in your post to Robotis. As he said it's not reliable but after a...
  12. Replies
    40
    Views
    14,461

    Re: Phantom_Phoenix on OpenCM 9.04...

    Thanks for the suggestions. Doesn't sound easy though... I tried using a DFRobot Xbee USB adaptor with a Micro B to Micro B cable from that to the CM 9.04 USB but the upload won't work. I was hoping...
  13. Replies
    40
    Views
    14,461

    Re: Phantom_Phoenix on OpenCM 9.04...

    Ok I have the Serial3 on the Cm9.04 connected to an XBee and it's communicating with the other XBee connected to the PC. So I've got a wireless Serial Monitor working which is good. Not sure what the...
  14. Replies
    40
    Views
    14,461

    Re: Phantom_Phoenix on OpenCM 9.04...

    Update to this. I got the Logic Analyzer worked out and pin 24 is outputting the correct text so the code and the board are correct. It must be in the serial connection back to the PC. I'll keep...
  15. Replies
    40
    Views
    14,461

    Re: Phantom_Phoenix on OpenCM 9.04...

    Ok I hooked up 2 XBees, one to the PC and the other wired to pins D24/D25 on the CM9.04 as I'm intending to use this as a wireless serial monitor. However found the following
    - I get no output in...
  16. Replies
    40
    Views
    14,461

    Re: Phantom_Phoenix on OpenCM 9.04...

    Ok, received the Sparkfun XBee Explorer Regulated board. I then cut off the end of the OpenCM904 comm port cable and soldered it to the XBee Explorer using the 3.3V pin on the Xbee as the OpenCM904...
  17. Replies
    40
    Views
    14,461

    Re: Phantom_Phoenix on OpenCM 9.04...

    7335
    Making some progress with the OpenCM. I've mounted it on a couple of standoffs so I can alternate between it and the Arbotix as I work through the migration to the new board. I've got my Lidar...
  18. Replies
    40
    Views
    14,461

    Re: Phantom_Phoenix on OpenCM 9.04...

    Hi Kurt, I've been working on replacing the Arbotix board on my PhantomX with an OpenCM 904 following your suggestion on another thread. I bought a 904a (no connectors) and the connector kit. I then...
  19. Replies
    7
    Views
    2,480

    Question(s) Re: Hexapod Randomly Freezes

    Good news. I replaced several cables but the main culprit was one with a couple of nicks in the insulation. I'm pretty certain it was shorting out on the frame. Anyway, after replacing that one and a...
  20. Replies
    7
    Views
    2,480

    Question(s) Re: Hexapod Randomly Freezes

    Yes I had a close look at the wires but can't see any damage so I'm hoping it is an intermittent internal break. When my new cables arrive I'll replace the suspect ones and see how that goes. It may...
  21. Replies
    7
    Views
    2,480

    Question(s) Re: Hexapod Randomly Freezes

    Thanks for the advice. I'm now inclined to think it may be a short in one of the wires as moving the robot does seem to bring the problem on. it seems to be associated with one leg. I've got some...
  22. Replies
    7
    Views
    2,480

    Question(s) Hexapod Randomly Freezes

    I've got a Hexapod MK3 which has developed a tendency to freeze at random. As I had made some changes to the Phoenix code I went back the the original Arduino 1.6 Phoenix beta code with Kurts...
  23. Replies
    6
    Views
    2,507

    Question(s) Re: How to Configure 3 XBEES in a mesh

    Thanks for all that advice. Much appreciated
  24. Replies
    6
    Views
    2,507

    Question(s) Re: How to Configure 3 XBEES in a mesh

    Thanks for the input guys. Much appreciated. I'll look into all this but at this stage I'm inclined to acquire a new board. The Robotis OpenCM9.04 boards have 3 UARTS and can be built to accept the...
  25. Replies
    6
    Views
    2,507

    Question(s) How to Configure 3 XBEES in a mesh

    I would like to have 3 Xbees configured in a meshed network as follows
    First Xbee in the Hexapod on an Arbotix board connected to a PC with a second XBee
    A third Xbee in the Commander2 Controller...
  26. Question(s) Re: How to do Wireless Upload of Sketches to Phantom Hexapod

    Update to this

    Lock fuse =0x0F
    Low Fuse = 0xFF
    High Fuse = 0xDC
    Extended Fuse = 0xFD

    The lock fuse doesn't look correct as it looks to be in Boot Loader Protection mode 3.
    Should I write...
  27. Question(s) Re: How to do Wireless Upload of Sketches to Phantom Hexapod

    Hi,
    I made some progress with this. I soldered a wire to DIO6 on the bottom of the Xbee socket on the Arbotix board and brought this out to a level converter on the 3.3v side. I then connected the...
  28. Question(s) Re: How to do Wireless Upload of Sketches to Phantom Hexapod

    Thanks for that. I can see how this would work as DTR goes low when you try to upload a sketch and looking at the arbotix schematic this is connected to RTS which then connects to the Reset pin 9 on...
  29. Question(s) How to do Wireless Upload of Sketches to Phantom Hexapod

    Hello
    I have a PhantomX Hexapod and am able to upload sketches using the UartSbee-FTDI serial connection or via an ISP. They both work fine but I've read that it's possible to upload wirelessly to...
Results 1 to 29 of 29